Replies

                • I keep getting autotest.py not found...any ideas?

              • Hi Randy,

                I use this command in the ArduCopter directory, (../Tools/autotest/autotest.py build.ArduCopter fly.ArduCopter logs.ArduCopter --map) but there is a fail says "bind failed on port 5760 -Address already in use"

                Will you pls give me some suggestion? Thanks in advance.

                Here are some pics while I'm running.3702898106?profile=original

                • Hi Terry, have you solved this error? thanks. I have your problem.

  • I have been trying to get SITL up and running the last 2 days.
    i have tried to follow the guide in the dev wiki for sitl on windows and sitl on linux

    i have had some trouble understanding how the system works. the wiki doesn't say much about how SITL works it's just a step by step guide that assumes that everything just works.


    Well i have run in to some issues:
    -The paths that are in the wiki don't work since MAVproxy was not installed in home directory,
    so i had to change the path to:
    export PATH=$PATH:/usr/local/lib/python2.7/dist-packages/MAVProxy
    export PATH=$PATH:/usr/local/lib/python2.7/dist-packages/pymavlink/examples
    (And .bashrc is hidden by default in ubuntu)
    Then i had difficulties with windows line endings. so i had to figure that out.
    i figured out that i could not add --viewerip=xxx.xxx.xxx.xxx to sim veichle.sh but had to use --out=xxx.xxx.xxx.xxx:14550 insted to get missionplanner in windows host system to connect.
    i also had some other problems that i can't remember right now.

    Anyways.... i now have SITL running with:
    "sim_vehicle.sh -L AVC_copter --console --aircraft test --out=192.168.56.1:14550" (in ArduCopter directory)

    i can connect with APMPlanner2 in the VM and i also have a connection with MAVProxy on windows and Mission planner on windows.

    my problem now is that the copter starts at gps pos 0,0

    [b]what is the issue here? i have supplied -L AVC Copter but it still starts at the middle of the sea?[/b]

    i would like to be able to fly the copter using these commands in MAVproxy:
    -param set ARMING_CHECK 0
    -arm throttle
    -rc 3 1600 (take of in stabilize mode)
    -loiter
    -rc 3 1500 Hoover in position in loiter mode.
    -land (witch would land in the current position)

    i have tested this when the copter is at gps o,0 middle of the ocean but it doesn't respond to all the commands. APM Planner says no 3D-Lock

    [b]why isn't the copter geting GPS 3D-Lock?[/b]

    when i get this up and running i'll go trough the dev wiki page and add what i have learned as a first timer using SITL.

    • I got it running by changing "nice" in sim_vechile.sh to "python"
      where does "nice" come from?

    • can't help you further, sorry, but you can try to use one of the other two SITL programs... I used sim_arducopter_randy.sh

  • Can you copy a windows equivalent of "cmd->ipconfig/all"  here?

    Is the SITL running on your ubuntu computer or another one?

    Menno

    • I got it working by adding --out 192.168.56.1:14550 instead of using viewerip=

  • I'm trying to set up SITL, but I already have problems in step #1.3 : first, when configuring the hardware I get a warning:

    "powering on the virtual machine will fail because it is configured to use more virtual processor cores than the host supports"

    when trying to make the number of cores "4".

    Second, there is no "Hard Disk (SCSI)"  in the list... :-(

    What should I do?

    Maybe already some questions in advance

    1) step #3.2: "where the ardupilot software is installed", do you meen the ArduCopter folder that holds ArduCopter.pde etc.?
    2) step "connecting with missionplanner: should you start MissionPlanner on Windows while SITL is running on the Ubuntu VM? Or should you install MissionPlanner seperately on the Ubuntu VM as well?

    Thanks, Menno

    • Developer

      Menno,

           MP should be running on your windows machine.

This reply was deleted.

Activity

DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
DIY Robocars via Twitter
RT @circuitlaunch: Last but not least, mystery guest @BostonDynamics Spot took to the track @diyrobocars He enjoyed the #brazilianbbq too 😂…
May 22
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race @circuitlaunch for @diyrobocars with @a1k0n Was busy in the morning and did not get a chance to tune camera…
May 22
DIY Robocars via Twitter
RT @a1k0n: This was epic. My car was barely working this morning, had to make a lot of changes and extremely dirty hacks. Post-race analysi…
May 22
DIY Robocars via Twitter
DIY Robocars @ Circuit Launch, 3/7/2020 https://twitch.tv/diyrobocars
May 22
More…