Sim using Flightgear only stable in Acro works

Im trying to get sim and Flight gear working, but all the settings Ive tried apart from Acro, the quad swings/yaws  from side to side constantly. 

Ive tried stabilize, stabilize simple, all the set modes with and without simple, autopilot and yet all swing side to side soon as I flick the switch.If i make any correction or pitch or roll it goes even worse.

In acro it works ok, it just seems to be in manual though with not return to level if you let the stick off to centre.

I installed the latest hil firmware , MP software and calibrated all the settings.

Ive tried altering the PIDs and have managed to reduce the yaw oscillation, but cant get rid of it all together. But what ever the case it is unflyable with this yaw oscillation.

Reading the forums it seems Im not the only one with this problem and most have the same issues, so any help would be very much appreciated by many.

Please help and advise what I am doing wrong here? Thank you in advance. John

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Same issue for me...

    I'm using last version of Mission Planer on Parallels Desktop in Snow Leopard.

  • Can anyone help on this please? After all the looking around and comments from others (on different post) there does seem to be a problem with HIL/FG firmware

This reply was deleted.