Slow data transfer rate - SOLVED

This is just a little annoyance but hoping somebody can give a solution.When Connecting my APM's (2.5 & 2.5Mega) in MP the read speed is quite slow, maybe 5x.How do I know this. Previously I've had to Erase the EPPROMs and the first time I connect it's speed is fast. After that it goes back to being slow.This happens on both my Boards.I've used different USB cables. Same through Telem.Did it on my old PC running XP & now my new one on Windows 8.Tried turning off Anti Virus software.Any suggestions would be welcome.Thanks in advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • PROBLEM BUSTED.......but.....

    Thanks for your help JD & Mike.

    It was as I suspected after all. The SR0 & SR3 Parameters were not at the original 'default' values.

    I Erased the EPPROM and noted the Values. I then loaded my Parameter file and changed the SR values back and all seems good.

    I have only tried this on my spare board.

    Next question: What impact do these setting have, especially as some relate to telemetry etc.?

    I've included the Comparison Chart with the default values on the left and one from my parameter file on right.

    3692826878?profile=original

    Interestingly in the Parameter List the range is shown as 0 - 10 Hz yet SR0_PARAMS is set at 50???

  • The speed problem is over USB and Telem on two different boards over 3 Comm Ports. The Telem signal is 100% as they are practically next to each other.
  • Hi,

    Seems your port settings could be the cause.... Please check your port settings while using MP....

    Set your port at highest speed.

    Are you running from a notebook or from a desktop? Check if power saving mode is enabled for ports....

    Just a few thoughts since you said that on first connection it was fast.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…