Hello,I built my quadcopter with APMcopter/Arducopter and I use Mission Planner on Windows to fly it. There are no extra external sensors such as compass or GPS or cameras - I have those but didn't install them just yet - and want to try out the basic functionality of the quadcopter.In Alt Hold mode the quadcopter flies perfectly well and when I first tried the Stabilize mode, the quadcopter also flew just fine with that. But after I landed it that first time in Stabilize mode, I can't fly it in that mode anymore.The front two motors spin up normally, but one of two rear motors doesn't spin up unless I add quite a bit of power, and the other one spins much slower than the front one. It still reacts to inputs, but when I try to lift off, it flips over since the front motors spin quicker.In the "RAW Sensor" window in Mission Planner I can see that the apmcopter software gives less power to the two rear motors than the two front motors. So the quadcopter does this on purpose, it's not a defective ESC or motor. Furthermore, the Alt Hold mode works just as well as it did before.I calibrated everything and it doesn't change the behaviour. Basically, the quadcopter behaves as if it was tilted forward (nose down), and counteracts that by giving more power to the front motors.But it's calibrated just fine and the Alt Hold mode confirms that. All inputs respond, there is nothing defective whatsoever. It seems like a bug to me, but I didn't find any other users reporting the same issue, and I can't update the software because I am out in nowhere and only have my phone with slow internet to post this question.Thanks for your help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Yeah I know that the DJI esc's can't be calibrated... but what I did do was to alter the CH3 MIN to 1120, and that made the esc's and motors more responsive and in synch with one another..

    But glad that your system is all working as it should... could have been a glitch all along....

  • I see. Well, for the DJI ESCs I have it is not possible to calibrate them (if you try, it won't go into the calibration mode), it's simply not necessary.

    I tried flying the quadcopter again today after letting it sit for three days. Guess what - the Stabilize mode worked flawlessly now, just like it did the first time. It started to rain so I couldn't test it for more than five minutes, but during those five minutes it worked.

    There has to be something that breaks the mode sometimes, but not always. I am out in nowhere, so there is nothing that could possibly interfere with anything...
  • just been told that because I am using DJI E300 esc's that I needed to adjust a setting in the FULL PARAMTER TREE..

    I have attached a screenshot.... I was having probs with motors not all spinning up in sync... I adjusted the RC3 MIN to 1120 and wrote parameters back to the Pixhawk... took the craft outdoors and all motors were in sync...

    rc3.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3702275294?profile=original
  • no worries, hope you get things sorted out soon....

  • It certainly can't hurt, but as I said: In Mission Planner I can see that the APMcopter software gives less power to the rear motors, so it's something that will have to be resolved via APMcopter, not with an ESC calibration. If there only was a troubleshooting guide for APMcopter that had anything remotely helpful. I have read through everything I found so far and there doesn't seem to be anything usable.
  • I use the DJI  E300 on my Hexacopter... but I still performed an ESC calibration.... not saying that it will make any difference... but it can't hurt to try.. ;-)

  • I did not perform an ESC calibration because I use the ESCs from the DJI Flame Wheel F450 set and those do not require calibration.
  • you said you calibrated everything... did you perform the ESC calibration as well???

  • You seem to have misunderstood. The quadcopter is placed on a flat surface, set to Stabilize mode. I arm the quadcopter and add power. The two front motors spin normally, one of the motors in the back does not spin and the other one spins very slowly. Once I add enough power for it to take off, the quadcopter instantly flips backwards onto its back. It has to, since the two front motors produce much more thrust. But that is certainly not intended behaviour now, is it?

    There is no wind involved or anything, calibration is done successfully and the Alt Hold mode works normally, as in, all four motors get power. The first time I tried the stabilize mode, it worked fine too, but now I tried more than a dozen times and there is no difference. Does this clarify it?
  • Congratulations on your conclusion "ap does that on purpose"
    Now ask yourself, what would happened if two motors actually produced more thrust, as commanded ?
    As long you hover in insignificant wind, and CG is about center, and ESCs are calibrated, and motors produce thrust as commanded, then you should see all work about the same.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…