This is a fresh build, after I just setup everything right, i had 1 battery time of wonderful flight!

On the 2nd battery, there was a very minor crash, after it it started constantly yawing around itself (i think it was in loiter but not sure) and when crashed I couldn't even disarm it with the stick to the left.

It was actually really scary to grab it and turn it off with the 10inch props looking for a kill.

Attached are pictures of the build. My main concern is that the GPS and compass might be too close to the insides.

Under the black dome you've got the pixhawk, stacked under it the qbrain 4in1 esc, then the carbon center plate, under it the receiver, then the bottom carbon plate and there the battery.

How I can make sure that it's the hardware causing the trouble and not something else?
I don't have gps mast at the moment and will take time for one to arrive, so would like to make sure that is what I need and there is no other major problem.

I'm really unexprienced so any help or thought might be useful for me.

Thank you all!

20150606_104040.resized.jpg

20150606_104049.resized.jpg

20150606_104103.resized.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi,

    as always providing us your data-flash log of that flight would help us.

    Downloading Dataflash logs

    Do you changed any settings in your radio after radio calibration (trims,endpoint,...)?

    Patrick

    • I believe this is the flight and this is the file I should upload?

      I was unable to make it auto analyze or make it paint a graph in Apm planner, hmm

      15-06-06_19-38-30.bin

      • Hi,

        I've done an Auto Analysis: check the compass line!

        ____________________________________________________________

        Log File C:/Users/adidas/AppData/Local/Temp/tmpD0D.tmp.log
        Size (kb) 9903.8798828125
        No of lines 133637
        Duration 0:28:45
        Vehicletype ArduCopter
        Firmware Version V3.2.1
        Firmware Hash 36b405fb
        Hardware Type
        Free Mem 0
        Skipped Lines 0

        Test: Autotune = UNKNOWN - No ATUN log data
        Test: Balance/Twist = GOOD -
        Test: Brownout = GOOD -
        Test: Compass = FAIL - Large change in mag_field (162.84%)
        Max mag field length (991.41) > recommended (550.00)

        Test: Dupe Log Data = GOOD -
        Test: Empty = GOOD -
        Test: Event/Failsafe = FAIL - ERR found: CRASH
        Test: GPS = GOOD -
        Test: IMU Mismatch = GOOD - (Mismatch: 0.33, WARN: 0.75, FAIL: 1.50)
        Test: Parameters = GOOD -
        Test: PM = FAIL - 54 slow loop lines found, max 11.88% on line 86727
        Test: Pitch/Roll = FAIL - Pitch (-56.01, line 69161) > maximum lean angle (45.00)
        Test: Thrust = GOOD -
        Test: VCC = GOOD -

        ____________________________________________________________

        I also checked some values of your log:

        Does your power module work correctly? I didn't see any current value...maybe you selected a wrong input?

        Do you checked the voltage measuring of you power module? 

        My power modules were all some 0.1V off. Thats very important if you rely on your battery-failsafe!

        Please consider increasing your FS_BATT_VOLTAGE. You going down to 3.15V per cell(if your power modul measurement are correct ;-) )

        If you use 10.5Volts as FS_BATT_VOLTAGE you have 3.5Volts per cell and you able to landing safely with some margin. 

        Oh almost forgot: I think your GPS/Compass should be mounted higher to get some space between power lines and ESCs.

        I hope, I don't take it to serious ;-) i just want to help :-)

        Patrick

        • Wow this is some great information Patrick, you are a life saver!

          What I found is that my GPS has been mounted incorrectly, because of confusing instructions. I'll be fixing that tomorrow.

          About the power module, I can see the voltage on the telemetry on Droid Planner 3. Actually the voltage failsafe kicked on my first flight and it landed. At the last few metters it almost free fall because hte battery was so drained so your second suggestion is also on the spot. I'll be increasing the failsafe voltage.  But I don't know why that is not seen in the logs.

          I suppose those analyses can be done only in Mission Planner and that is not available yet in APM planner? That would be a pity.

          Thank you again Patrick, that kind of help is exactly what newbie like me needed in this sometimes intimidating hobby.

          I'll be starting with fresh motivation tomrorow :)

          • Yeah I tried APM Planner as well. I was running it on Debian Wheezy but Mission Planner under Windows is more stable. 

            Maybe in a few months or so it will be better. Right now I'm running Dual-Boot with Windows 7 and Debian. Mostly because of Mission Planner...

            The voltage from the power module was visible in the logs but not the current.

            Patrick

            • yes I don't see the current either, but thought it was because i was stationary at the time.

              No idea how to approach that problem though?

              I'll look closer at how to inspect logs in APM planner then. Didnt figure it out the first time :)

              • Well, hard to tell from far away... but the parameters regarding the power module are right.

                Maybe you can take picture of your power module and/or connection to your Pixhawk. 

                It could be a bad solder joint, too. Or the cable... There are some possibilities... ;-)

                Patrick

  • please do compas mot test to see if you have emf issues

    • I've tried that but the graph stayed empty.

      I have power module, and was able to throttle up during the test but the graph didn't react at all. 

      I'm with APM planner because I don't have windows OS

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
More…