stuck at failsafe, where can i find what is wrong

Hi Guys

The next instalment of questions from a newbie.

my HUD in mission planner shows failsafe and will not allow me to alter flight modes. It will arm via the safety switch and responds, apparently correctly to throttle input.

Clearly it is not happy with something but is not reporting to HUD screen an RC failsafe condition., just failsafe.

I am at a loss to diagnose this until i know what it thinks is wrong, where do i look please  ?

Thanks in advance

keith

3.2-rc3

1.3.7 mission planner

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The compass is in the same place as when i did not have this issue.  3DR GPS with compass inbuilt.

    Can anyone confirm this will give a failsafe condition.

     

    Will re do the compass dance tonight anyway but if this were the cause would i not expect an "RC failsafe" condition ?

    • SOLVED

      It appears that RC3 will not allow me to have failsafe set to disabled. As soon as i select  RTL  on defined failure everything is good to go. See my other thread , i have now flown 3 short test flights and everything is stable and reliable.

  • Download the log from APM or Pixhawk
    • I hope this works and is useful

      Oops file too big. will have another go

      • attempt #2

        2014-07-31 20-01-52.log

        • Since you say you are a newbie; (which is ok, we have all been there) 

          - avoid testing beta/RC firmware, until you are sure everything works fine with current release.

          Current arducopter is 3.1.5  , you are trying 3.2-rc3  ,

          You could also try  FS_GCS_ENABLE = 0

          The proper approach would be : install current firmware, 3.1.5  - tune everything, make sure it flies perfectly and get used to how it behaves "normally".

          Then review releasenotes/and or code changes before installing a beta/release-candidate, then do some careful tesing,  test every affected feature in a safe way.

          • Hi Andre

            Received and understood, however, i moved away from 3.1.5 because 3.2 has a safety arm switch bypass and i was previously having huge issues with ESC calibration. I believe that is now resolved.

            I dont want to bypass failsafe which i guess is what your parameter change is advocating, i dont know i have not had a chance to connect and read it yet. What i want is to understand what causes the issue because i cannot determine that as yet.

            I could of course initialise the firmware, reload and start everything again but that is a pain if there is an explanation available. The same thing might still be present anyway.

            Thanks again for your time

            keith

            • ok, I see.

              Not knowing exactly what you've done (or connected, and how),I tried to make you bypass the need for telemetry radio connection to GCS - ground control station.

              I just guessed that may be the cause, yet I don't see the proper log entries to confirm that.

              Did the same config arm properly with 3.1.5 ?

              • I tried 3.1.5 on a previous Pixhawk unit that was returned to the supplier as it stopped working.That unit and config did fly once, briefly.

                The replacement has so far only been used on 3.2 and has not yet left the ground. I thought i was ready to go and yesterday noticed that i could not vary flight modes and the aformentioned failsafe is prominently displayed in the middle of the HUD.

                Strange that i can run up the motors when a failsafe condition exists, if i had props on it would have taken off of course.

                This is not the same as an RC failsafe.

                Still confused

                • Log analysis gives me this output....

                  Log File //pdgstvfps02/home$/mann_k/My Documents/Downloads/20140731200152.log
                  Size (kb) 1087.2861328125
                  No of lines 15092
                  Duration 0:01:04
                  Vehicletype ArduCopter
                  Firmware Version ArduCopter
                  Firmware Hash
                  Hardware Type
                  Free Mem 0
                  Skipped Lines 0

                  Test: Brownout = PASS -
                  Test: Compass = FAIL - Large compass off params (X:-60.00, Y:-48.00, Z:-222.00)
                  Large compass offset in MAG data:
                  Z: -222.00
                  mag_field interference within limits (2.46%)

                  Test: Dupe Log Data = PASS -
                  Test: Empty = PASS -
                  Test: Event/Failsafe = PASS -
                  Test: GPS = PASS -
                  Test: Parameters = PASS -
                  Test: PM = PASS -
                  Test: Pitch/Roll = PASS -
                  Test: Underpowered = PASS -
                  Test: VCC = PASS -

                  The compass dance thing is getting to be a pain.

                  Is this my issue? i remember a warning about dual compass or something but do not fully understand the implications. I will re do the dance this evening.

This reply was deleted.

Activity

DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
17 hours ago
DIY Drones via Twitter
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
Friday
DIY Drones via Twitter
Thursday
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Thursday
DIY Robocars via Twitter
Thursday
David Hori liked Isabella Domi's profile
Jan 12
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Jan 11
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
DIY Robocars via Twitter
An interesting line-following simulator to use with with your robocars: https://github.com/ron-grant/LFS
Dec 23, 2020
DIY Robocars via Twitter
Dec 23, 2020
More…