Suicidal APM 2.0

This clip demonstrates recent problems with Return to Launch mode on my APM 2.0. In the clip, launch is behind and to the right of the aircraft. I've left the landing sequence in the video to show where the plane was launched from (I land very close to the launch site). What you see and hear is the plane flying level. I then switch to RTL mode. You hear the motor change speed. This seems normal to me. Then the plane begins to circle to the right as if it is returning to launch, but instead continues nearly 360 degrees. It seems to level out for a moment but then begins a death dive continuing to circle to the right. I switch back to Stabilize mode and take control of the aircraft. Then I land.

I noticed this last weekend and have been trying to solve the problem all week. Additionally, Stabilize mode is not working properly. If I let go of the controls, the plane noses down slightly and turns slightly to the right. This is similar to the RTL problem, but not as severe. No amount of trimming the aircraft helps, or seems to change anything at all.

Here is what I have done to try to correct the problem. I have tried to recalibrate the gyros using the mission planner software. I have recalibrated my tranmitter. I have reflashed the APM with latest Arduplane firmware. I have shut down my video tranmitter and tried activating the RTL mode without it running.

The most recent change I made to the aircraft, which somewhat coincides with the time I first noticed the problem, was the addition of a Bluebeam circlarly polarized antena to the 1.2 ghz video transmitter. Removing this and shutting down the tranmitter does not solve the problem.

Any suggestions would be greatly appreciated. Thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • 100KM

    Oh, and this is what I call a suicidal APM... https://www.youtube.com/watch?v=17GaSx7UbJY

  • Developer

    Hi Brian,

    Do you have a tlog of the flight? If you do then please post it and I can take a look.

    Cheers, Tridge

    PS: It won't be an issue with logs filling - the logs wrap when full

  • 100KM

    Just a few things to check:

    1. Do you have 3D lock on GPS?
    2. Is your RTL altitude correct? There is more than 1 place to check if I remember correctly.
    3. Has the APM been properly leveled? Confirm this by ensuring that your APM artificial horizon is level while flying level.
    4. Check your logs during the RTL and compare with your video, does the banking etc of the sensors agree with the video?

    I agree with Clayton - almost all of the time weird behaviour is because of the operator.

  • I've had things like this happen before and it's always my fault. Usually a matter of incorrect trimming or more likely the ardupilot has one or more control surfaces directions reversed. Check it on the ground (nice and level) in manual mode first. If everything moves in the correct directions, flip to stabilize. If trimmed well, no surfaces will move when you switch. Also, pretty sure I still use "trim auto = on" so the APM uses your transmitter inputs at the time of switching to stab/auto as the nuetral positions. If everything looks good for trimming, pick the airplane up in stabilize mode and make darn sure the APM moves surface in the correct directions when you roll and pitch. If rudder is mixed in with roll, make sure it goes in the correct direction. (If you're flying an airplane with right wing down bank, you should use left rudder to help.)
    Good luck.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…