Tarot 2D gimbal and Pixhawk - Tilt control

Hi everyone,After spending almost my entire Sunday trying to get this work, I finally thought that asking here might be wise...Here is my problem:I can't get to control my tarot gimbal tilt from my RC through the Pixhawk.I think the Pixhawk is running the latest apm version (I updated it a month ago).I've found two different wiring instructions.- Here, using 3 cables: http://3drobotics.com/wp-content/uploads/2014/02/Tarot-gimbal-kit-quady6x8.pdf- Here, with 2 cables: http://copter.ardupilot.com/wiki/common-tarot-gimbal/None would work for me.With the 3 wires option, the gimbal turns and locks facing up/left.With the 2 wires option, the gimbal behaves like it's working independently (i.e. stabilizes nicely, keeping the camera straight, but now way to command it).I checked in APM PLANNER, RC calibration, the knob (pot) I want to use seems correctly mixed to channel 6 and I can see the gauge moving on the calibration page.So it seems that it is not something on the RC side or the Rx.Btw, I use a turnigy 9x flashed with the er9x firmware. The receiver is a FrSky D8r-II plus flashed with the XP firmware to get PPM.I also followed the wiki instructions to configure the gimbal in the mission planner.I uploaded the 3dr settings to the gimbal with the tarot flashing software.And the gimbal is running the 1.4 firmware.So please, can anyone help me find where I'm messing up?And as a starting point: is it a 2 or 3 cables wiring needed to the pixhawk?Many thanks for your help,Mathieu

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

            • Mine does level and track horizon without the wires hooking it to the Pixhawk.

              If I connect it to the pixhawk, I can crudely adjust it by changing the Gimbal parameters, but alas not with the AUX knob yet.

              • Chris,

                What radio do you have?

                I think I might start a new thread

      • I - I've performed the calibration a few times over having it set up.  Camera on its back, pointing at the sky and as "level" as I can make it.  After the calibration is looks like its reading zeros on pitch/tilt/roll when the camera is pointing straight ahead.   Unfortunately that doesn't "unlock" anything for me.

        As for servos, I don't have one to connect to it, but I know that the pixhawk is outputting *SOMETHING* as I'm able to move it to different AUX channels and verify that it's talking to something.  As I mentioned, I can change the pixhawk settings and get it to move around consistently, but I just can't get the RC6 or RC7 channels from the AUX1 or AUX2 channels of my Spektrum DX7s to do that through the Pixhawk.  I know the channel is working and calibrated.  Just no joy.

        Still out of ideas.

        • Solved!

          It turns out if you've ever clicked on "Point Camera Here" in APM Planner, it will do something like a "Do-Set-ROI" which changes the value of the parameter MNT_MODE = 2 (MavLink_targeting), with the result being that it will forever ignore the inputs coming from the radio.

          Setting MNT_MODE = 3 (RC_targeting) lets it listen to the radio again.

          Perhaps I'm using APM Planner incorrectly, but this is probably in need of an interface improvement.  Also, it would be good if this behavior were mentioned on the Ardupilot "Tarot Gimbal" page and other pages on interfacing to Gimbals.

          I also think that calibrating the interface could be documented better.  Probably will start a new thread for that.

          • Thanks for this, I've spent most of the day today trying to figure out why my pixhawk isn't talking to my (fake) alexmos controller.  With a multimeter I eventually worked out that the aux pins on the pixhawk are only outputting a resting 0.26v and doesn't change.  

            Changing mnt_mode to 3 (which was 0 for whatever unknown reason) and setting the gimbal tilt setup to what is recommended in the wiki tarot setup (1000-1520 servo, -90 to 0 angles, rc6->rc9), I now get variable output on rc9/aux1 from 0.18v to 0.26v, if I change servo limits to 1000-2000 it then goes from 0.18v to 0.34v.  However this isn't doing anything to the gimbal, as it's expecting higher voltages I guess, and I'm expecting to get 3.3v from the aux pins.

            Any ideas?

            • It's not clear if you're using the Tarot gimbal controller or not.

              Two things I was reminded of when upgrading to AC3.2-rc6

              • Make sure the blue light on the Tarot Control board is flashing (it's receiving external commanding)
              • Make sure that BRD_PWM_COUNT is non-zero (I use the max of 6).
              • I'm stuck in the same situation (Tarot board seems to be working, though a little afflicted by jello even before the props turn, but no response to the Aux 1 even when all the settings discussed are applied.

                Well, all that I can find.

                That said, I don't see a blue flashing light on the Tarot Control Board (unlike when you have the USB attached), nor do I see a BRD_PWM_COUNT option in APM.

                It's incredibly frustrating. Wish I'd got the DJI Gimbal now.

                Anyway, what should my next move be? Do things like RELAY_PIN matter? OR RCx_FUNCTION?

                • I'd make ultra-sure you've got the wire pinouts correct.  You might need to use Mission Planner to gain access to the BRD_PWM_COUNT which could have possibility defaulted to something non-usable.  I don't think RELAY_PIN matters, but RCx_FUNCTION will when you confirm the "blinking blue light" for connectivity, and need to pass through the RC commanding.

              • Seems like Don is not using the Tarot controller but an alexmos clone.

                For different reasons (mounting the gimbal front facing on my TBS Discovery being the main one) I've dropped the Tarot gimbal for an alexmos controller + brushless motors and 3d printed gimbal.

                My control board is directly connected to the radio receiver.

                Haven't tried to connect it through the Pixhawk so I don't know if it's compatible...

                Cheers,

                Mathieu

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…