Tarot 2D Gimbal ignores controller after upgrade

I have just upgraded my Iris Tarot Gimbal to v1.5 while changing the motor power settings to get rid of Jello.

Now my Gimbal just levels itself and then looks downward and will not respond to the controller tilt anymore. I'm assuming this is something to do with the update. I have tried it wired like in this video http://youtu.be/aHkfuRddrOY look at 1:30

which is the way it was, and also the other way http://copter.ardupilot.com/wiki/common-tarot-gimbal/ 

But i have no tilt control. is this something to do with controller type in the software?

the Gimbal will stay orientated when I move the iris round.

Any help much appreciated 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I screwed up the wiring once after upgrading and thought the same thing.  The wires going to the pixhawk look weird in the instructions.    Try using the components in the photo as a reference.  My Gimbal points straight down without the wires attached. (or before I turn on my radio)

  • The standard settings can be found here. They are also referenced here: http://copter.ardupilot.com/wiki/common-tarot-gimbal/ 

    • Thank you for the link, don't know how I missed that page.

  • Try "write settings to flash" after ensuring it is set to MODE2.

    I had that same exact issue.

    • thanks, that did the trick. I couldn't get the software to change it to Mode 2 so i had to load the standard config file. all good now, did 50 minutes flying today and worked perfectly

  • Sorry if you've done this already, but did you upgrade both the controller firmware and the motor firmware? You'll also need to recalibrate the camera position (level, facing straight down) and reset the min/max tilt. I messed with this update for a while and got it working, the jello is indeed gone.

    • I emailed 3DR when I went through this to see if they could let me know what the factory parameters on the gimbal should be since they're reset after the update, but no luck. Like the TX settings, gotta just noodle it through I guess. If I recall, there's also a tricky setting in the firmware in regards to how it handles TX input...anyway, it's all here (except for the calibration)..

      http://youtu.be/A2WXguD2Ghs

  • Make sure the R/C transmitter is on. With the R/C transmitter off, the Gimbal will point down. 
    Also make sure that the cable from the Pixhawk to the Gimbal is correctly connected. 

    • when I plug the wires on the bottom of the iris in, it always points straight down. if I power it without these wires plugged in it points horizontal. Now I'm very suspicious of the upgrade stuffing something up.

      In the gimbal software, what receiver type should it say?

    • which wiring diagram is correct? or doesn't it mater

This reply was deleted.

Activity

DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
More…