Telemetry - OpenLRS and APM


I have been trying to get telemetry to work with my OpenLRS RX and TX. Been trying out different setups and baud rates but not got it to work.


The transparent serial bridge is working perfectly but when I try to connect the RX to the APM Telemetry port (port 3) I cannot connect via Mission Control. Running a serial monitor I can see traffic - ascii in the beginning saying something like "<startup_mode: ground>" and then binary. Seems to be ok... but not good enough to connect.


I think the problem might be related to bandwidth. OpenLRS supports 750 byte/seconds from the RX to TX. After looking at the documentation and source code I have not figured out how much data MAVLink protocol is configured to send per second.

Does anybody know?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • What radio and what tx/rx module do you have. Try to erase the eprom from your minimosd, burn the bootloader and flash again with the 19200 baudrate firmware version from the website and see if this solves the problem. 

          • Hi!

            By now I have tried flashing with the bootloader and the firmware from the site. Still not displaying any osd info, just video feedthrough.

            Any ideas?


            • Check the cable. If you have another apm, try flashing the minimosd with normal firmware (5700) and see if it's working.


              • Thanks. Tried with a second set micro APM and OSD. When connecting to the apm with openlrs I get the following behaviour:

                - No overlay when switching on (either one of the 2 minimOSDs)

                - When pressing the button on the OSD, I get an overlay saying minimOSD and the version. Strangely one osd says 2.4 r805 and the other 2.4 r719, although I tried flashing both first with the standard MinimOSD extra and then with yours. Received "done" message every time in the tool.

                - After pressing the button on the osd and waiting for booting to finish they both display "no mavlink data"

                When connecting the two minimOSDs to an APM without openlrs, I get the following:

                - The minimOSD with r805 displays the overlay fine right away when powering up

                - The minimOSD with r719 does not display anything, not even after pressing the button

                No clue what's going on. I have some hypothesis. Do you think one of the following could be happening:

                - Flashing is not successful, despite the "done" message. Could explain the different versions.

                - The minimOSD with r719 is broken

                What else could it be?


                • Try to flash the r719 to the working one, and the r805 to the non-working one. This way you will know if the r719 minimosd is broken. (Did you check the wires?)

                  • Cabling checked. Also I already get telemetry via the openlrs to the transmitter and that is on the same set of cables.

                    Tried both osds with both firmwares now. Looks like one is really not working. Does not display anything on my quad, while the other one does, independent of firmware. Both of the osds are out of HK micro apm set.

                    Got a third osd, which is the original minimOSD (bigger than the one from the HK micro set I had used before). Flashed with r805 and also says "no mavlink data"...

                    Will check my APM settings again.

                    Could it be that this has to do that I am using a microAPM from HK (and not a normal sized APM or Pixhawk)?

          • Thanks, AlbEagle. This is my setup:

            - HK micro APM set (incl. APM, OSD, etc.)

            - HK orange openlrs RX (100mW)

            - HK orange openlrs TX (1W) on a Turnigy 9XR

            Flashing the firmware from your page worked without error. So, not sure if that is the problem. However, I had not burned the bootloader. Will try this in 2 weeks, when I am home again.


  • Hello Martin.

    I am using Gitsly some month ago (not updated from months) and i have two issues, sometimes it lost bind and sometimes it lost full configuration, for example i am using PPM and i have to re-assign PPM to this channel.

    and with droidplanner i can not receive parameters and i can not send flight plans, all other fuctions works perfectly.

    Do someone have this wiorking exactly as 3DR radios?

    • Hi there,

      I have exactly the same problem as Jose 

      When connecting via 3DR radios in APM Planner everything works fine:

      Parameters downloads and I can Upload and Download Waypoints etc.

      I have tried various alternatives including using Openlrsng and ULRS but end up having the same problem:

      Parameters do not upload even when leaving for long periods, when I cancel the parameter upload, Airspeed ALT Roll and Pitch GPS updates without problem, but I can not upload or download Way points. It seems to timeout.

      Jose have you found a solution?

      • Hi there found the problem,

        The ground wire coming from the telemetry port was broken inside the insulation, new wires soldered in and all working now!!! 

This reply was deleted.