...that on some computers (like the one I am using right now), there are some other COM devices like GPS and some broadband adapters installted, which seem to have the option of forcing them into bootloader mode or at least talking to them through a serial connection.

In my case, I tried to flash a brand new Pixhawk with the current 3.2 plane firmware and nothing worked. So I finally tried the px4uploader.exe in the MissionPlanner directory. And voila! It searches the COM ports one by one and got stuck for a super long time when trying to access the onboard GPS on COM6 on my computer. After more than 30 seconds, it gave up on this port and finally managed to find the Pixhawk on COM15 and flawlessly uploaded the current firmware.

Whoever struggled with uploading firmware, it was not the USB cable, nor the OS or the Pixhawk itself or anything else. It was some other COM device attracting to much attention and wasting time.

A possible solution for this would be to give either more time for the uploader to find the Pixhawk, or remember the COM port used and give it to the px4uploader.exe as a parameter so it tries this one first.

I hope this helps others a bit.

With regards

Marc Kulhavy

Neue Bitmap.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…