Trouble reading inputs from receiver

Hello,

I just purchased an ardupilot mega and soldered input and output pins, but I am having trouble reading receiver inputs. I uploaded the sample program from Sparkfun found here ( Example Firmware ). Currently only input0 is being read correctly. 

With nothing plugged in:
All inputs read 1500

After plugging a receiver output to input0:
input0 is read correctly and some of the other inputs change to 1000

When receiver outputs are plugged into inputs 0-7:
No change and nothing appears to be read.

Any ideas? Is this a soldering mistake or a bug on the board? Also, at one point, only input4 was working and all others stopped working. I'm not sure why that could have happened.

Any help would be greatly appreciated!

- rusty

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have been experiencing some odd problems as well. With a JR receiver all channels work correctly. With a FrSky receiver the higher channels (4 upwards) sometimes lock for up to several seconds. They appear to hold their last value and ignore the input. After some time they suddenly start following the inputs again. I have confirmed it is the PWM->PPM conversion and not my code by monitoring the PPM output of the 328. You can clearly see the values sticking occasionally. Maybe the failsafe is too sensitive?

    Looking at the PWM outputs of the FrSky rx the outputs appear normal though the frame rate is slightly high at around 55 - 60 Hz. I haven't yet checked if the pulses are output in sequence or together.
  • I made some test with my APM, when are connected signals from input 0 to 5 and power on the APM, if i disconnect any input (0 to 5) and connect it in the other two free inputs, i can't see any response in the terminal, but if a make a reset in the APM, the new inputs begin to show the correct values and work fine.

    Maybe the PPM code (I couldn't saw it yet) in the first start up determine how may channels are conected, and if you make any change without a reset, may seem that something is going wrong.

    P.D. Sorry for my poor english.
  • Looks like my board was one of the bad batch as well.

    I have emailed Sparkfun for a RMA and will hopefully be getting it replaced.

    Original Order details:
    Ordered on 2010-06-03
    Shipped on 2010-06-04

    chris.
  • I am having lots of problems with my ArduPilotMega (and shield IMU?) boards. I got them soldered by an expert friend last night and tried the miniUSB input on the shield and was able to program it right away (just the ArduPilotMega_demo.pde). Thought everything was maybe fine but then hooked up my receiver and servos and ESC - just like I did for the ArduPilot. However, the ESC would not power it up.
    (1) If I separate the boards and power from an ESC, I get a dim PWR red light but the servos move as if in MANUAL mode. (no other lights and the demo program doesn't work - no change in servo movement depending on Ch5/6 input).
    (2) If I connect my older FDTI cable (and remove the ESC power), all the lights seem bright red/blue and I can download the test program but I see no printout change whatsoever if I change Chan5 or Chan6 and the servos don't move even though I have left the receiver hooked up.
    (3) If I connect the shield back on and use the miniUSB, I get lights and can program but can't power via the ESC and the servos don't move.
    Is something "busted"? Is it time to return the ArduPilotMega board to Sparkfun? Could it be the Multiplex chip? I had success with the older Ardupilot board but not here.

    Thanks for any help or advice

    Dave
    Move Inc.
  • I talked to Sparkfun and they said they would replace it.
    Earl
  • Should I send the ArduPilotMega back to Sparkfun for replacement as that's where I bought it ? I would like to get it sent and back this week!
    Earl
  • Chris,
    Should I send it back to you or Jordi ?
    Earl
  • Is there a way to read out the fuse settings w/o an isp programmer ?
    Can we hook an FTDI to it ?

    Earl
  • Not the joint either.
    I looked at where Ch0 goes on the chip and it is always high. If I unplug ch0 it still is high. Ch 0 cable has normal signal unplugged from board. Board pulls it high when plugged in. Sorta like that pin on 328 is programmed as an output and not an input on that pin.

    Ch1 and ch2 have RX sig (next 2 pins on chip as it should)

    Earl
  • Not the cable. I swapped RX cable 1 and 2. In0 still not work. Will now investigate solder joint
    Earl
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
2 hours ago
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
2 hours ago
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
2 hours ago
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
More…