Trying to incorporate a delay between landing and takeoff for water sensor application.

Hi All,

 

 I posted this over in ArduCopter User Group and got a few helpful responses but am still not having

success. My goal is to land at specific way points around a body of water, like a lake for instance, delay for about 30 seconds while the various water sensors obtain readings, then take off to the next way point repeating the process at several locations.

I have been successful at every aspect of this except the delay after landing and before taking off. I have tried "condition_delay" but that seems to have no effect. It goes from landing to take off instantly without recognizing the 25 sec delay.

Maybe it is not supported or i need to format it differently. 

I also tried to add a waypoint with the "add below" button, giving a 25 second delay, but no GPS  info, and then adding a "take-off" command following that. It seemed to be working, but then a couple motors started spinning up and I aborted. Shortly after my radio batteries died so testing will resume bright and early. 

If anyone has any suggestions I would really appreciate your input.

Views: 551

Reply to This

Replies to This Discussion

Can you post your mission file here please?

Some commands require a dummy waypoint after the command, don't know if this is the case here.

Here you go. I thought I needed the conditional commands in between two nav. commands but I thought that is what I had with the "land" and "takeoff". I appreciate your taking a look.

Attachments:

I'm not sure why it's not working, this may require one of the devs with knowledge of the inner workings of the code to say conclusively.

I've added the dummy waypoints to your file if you want to try it out. Sorry I can't help more.

Attachments:

I loaded that mission and will try it out first thing. I will let you know if it was successful. If so we should actually be able to demonstrate  usable data as we already have the sensor array built and working.

Graham,
Unfortunately that did not work as expected. I had described that shortly after landing a couple (3 and 2) start spinning up just enough to slowly lift the left side of the copter up. I have been aborting at this point to avoid damage. I am wondering if a throttle parameter setting could be affecting this, and I have been aborting prior to the takeoff command initiating. This same thing happens in a number of different scenarios I have tried.

So two motors spin before the others which starts to tip the copter over? That is normally the ESC's that need to be calibrated or you're on an unlevel surface. I don't think any throttle parameter will affect just two motors.

It's late here now but I'll try your mission in the morning to see if it'll work on my quad

Appreciate that. I have re-calibrated all of my ESCs although I am not sure that is the issue because it only happens in this situation. The land and auto take off work when I don't add in the "dummy" way points. But it ignores the Delay command. I'll keep working at it and look forward to hearing your results.

Sean, the delay is not working for me either, so I suggest you open an issue in the issues list: https://github.com/diydrones/ardupilot/issues?state=open

Has this issue been fixed I'm having the same issue where the copter ignores the delay after it lands on water.

Here is a video link: test flight

and here is a pic of the mission commands

Found the fix! turns out delay and condition delay don't do the same thing.

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service