Turnigy 9x ppm and failsafe

Hi all, first post, hope it's in the right section..

I'm currently trying to setup failsafe arducopter v2.3 and turnigy 9x v2 but I'm now stuck...

I set thr_failsafe = 1 and thr_fs_action = 2

I suppose that the failsafe function is enabled when all channel send 0-975 signal or the radio is swicthed off. 

Well, for what I'm seeing the original receiver of the turnigy 9x in PPM sends to the arducopter the last signal received. i.e. throttle at 60% and stays there,  unless you haven't enabled the failsafe function in the radio menu. But, as stated in the manual, it works only in PCM mode ( as far as I understand this is valid for other radios, too).

If I enable PCM mode, all the channells get crazy... throttle included... (no props attached!)

I'm pretty sure I'm missing something... if anyone can help it would be appreciated,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have the same radio.  Failsafe does not work in PPM mode.. just PCM. You need to do what I did.

    I bough a FRsky transmitter and receiver module.  I't worth the money, you will get better range too.

    Failsafe with the turnigy/frsky is a piece of cake.   I set mine for RTL.

    Make sure you set the radio up for it correctly, if you use the default settings all motors will stop and it will fall like a brick.

  • It works out of the box just fine if it's a genuine 3DRobotics APM 2.6, none of the clones I've bought from China have worked.

  • Stock Turnigy 9X with the stock 9X8Cv2 receiver has got a configurable failsafe for signal loss. 

    -Set the transmitter to PPM in SYSTEM SETTINGS->MODEUAT/MODULATION->PPM 

    -Set FUNC SETTING->E.POINT->THROTTLE to 120%/120% (This changes the maximum throw up&down. protip: move throttle stick to change value for up/down...)

    -Set FUNC SETTING->SUBTRIM->THROTTLE to -120 (sets the midpoint lower, so that the failsafe value goes to less than 1000

    -Set FUNC SETTING->FAIL SAF->THR->F/S 000% (This sets the failsafe (transmitter off) value to 0%, which goes -to <1000 since we changed the midpoint/endpoints. In my system, the failsafe value is 900 and min throttle 981.

    -Adjust your throttle trim and APM/multiwii/etc. failsafe thresholds so that the failsafe signal value is lower & failsafe is correctly activated in your autopilot. Poke, Test, poke and test. Don't rely on the default values!

    Note: My Turnigy transmitter&receiver are a few years old from Hobby King. Your results may vary. Tested on [SYSTEM SETTINGS->TYPE SELECT->ACRO] model type. Not sure if everything are the same for GLIDE&HELI. Also the Turnigy is a cheap-ass system, consider something better for anything valuable&dangerous. :)

    Some pics of menus: https://www.dropbox.com/sc/9qmdbg1m1fqkmvy/PNpV77VN0n 

    Turnigy9Xfailsafe (1) (6 photos)
    Shared with Dropbox
  • I am having a problem with a Turnigy 9xBC version 2 RX when there is an absent of a signal from the trnsmitter(turned off), it output the last value received from the TX signal on Channels 4 and 5.  I have gone into the transmitter setup, switched to PCM and tried to disable any failsafe setting there but the RX but it still outputs a signal on channels 4 and 5 regardless.  This is not good for the simple Servo to PPM encoder that I would like to use.

  • Please can I ask what you guys think of THIS motor.

    Thank You

  • As fat as I understand the failsafe in T9X is only working for PCM, and not PPM that the 2.4 GHZ modules uses, and as such not available.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25