Unable to connect to APM 2 board

I'm using Planner 1.1.14 with a new APM2 board. Win XPpro and the Atmega2560 inf driver file from the repository.

Planner loads and verifies the 2.27 firmware but it does not connect to the APM2.  I have used Putty and it does reset the APM2 on connect and I do see packets with mixed binary/alpha content (presumably MavLink).

When watching the APM2 board, it does not appear to come out of reset after Planner opens the port.  Since the reset step works correctly with Putty, it seems as though Planner is holding the reset line for some reason.

Should I add this as an "issue" ?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • My APM2 also can't connect using USB. It can update firmware fine though.

  • Hi there

    I have the same issues but the writed fixes here will not work.


    I can update the APM 2 to Hexa X V 2.4 and i wait 5min until i connect but every time the same:

    Mavlink Bad Packet (crc fail) len 0 crc 65535 pkno 0


    I also updated to the newest APM Planner: 1.1.38


    Does anyone has a working fix ? I think that is not a little problem, many of us has the same problem. It has now about 10 threads with this problem. 


    So please, if anyone have a fix for it post it with a short manual if we that need.


    maaaaaaaaany thx from switzerland



  • For me the new mp fixes the problem for 99% I still have sometimes the MP won't connect and the lights won't flash. After taking power off en puting power back it will be fine again.

  • I am having this issue also with apm2.0.

  • Michael--  I just downloaded version 15 and tested it here.  Unfortunately it now seems to hold the APM2 in reset regardless of the state of Reset-on-Connect.  Planner 14 still works without Reset-on-Connect checked.

  • I get the same behavior with my APM2 board.  When I connect to the board via USB, it resets, the ABC lights come on and there is some TX activity.  Then A(red) turns off and stays off.  When I look at the MissionPlanner console, I see the following:

    124 got param 163 of 172 name: RC6_ANGLE_MIN
    Init Gyro145 got param 164 of 172 name: RC5_ANGLE_MIN
    MAVLink readpacket read error: The operation has timed out.
    Mavlink Bad Packet (crc fail) len 0 crc 65535 pkno 0

    I am able to connect to the APM in MissionPlanner using the terminal.  In terminal, I run the IMU test and get the response InitGyro and then nothing. 

    One final note.  If I play around in terminal and then run the IMU test it works.  Once this works, I can connect normally until I power down the APM.



  • Thanks for your updates, I'm going to look for an AMP2 blog since this may or may not be a Planner problem.

    Just tried it again and here's what I see happening-

    1) Insert USB to APM2 board. It powers up, the red, yellow and blue status leds are active, the GPS led is flashing and there is TX activity on the usb port at about 2hz.

    2) Click Connect from Planner. All APM2 leds (except GPS) go out as though it is in reset.

    3) The Planner connect progress box appears and counts down to "0".  I see periodic USB RX activity but no other leds are active on the AMP2 board.

    4) The Planner connect progress times out and at that point there is USB RX and TX activity.  Planner throws an exception about not seeing heartbeats.

    5) When I close the exception message box, APM2 red, yellow and blue status leds come alive and there is again USB TX activity.  APM2 appears to start up normally.

    6) Open the port with Putty terminal emulator.  APM2 resets, I see the startup header and then mixed binary/ascii messages about initialization.

    As a cross-check, I just used Planner 1.1.14 to connect to an installed APM1 (red) board in a flying plane.  It came up and connected promptly as it always has in the past.

    The problem appears to be on the APM2 (purple board) side so I'm going to post a message there, too.

  • I am having similar problems. Every since I got my APM 2.0 board, connecting has been very hit and miss. I resorted to usng my Xbees by default. However, since updating Mission Planner to 1.1.14, I do not seem to be able to connect, either through the USB or the Xbees - it just times out, even when I have a GPS lock. I have checked the baud rates for both the USB and Xbees. I have used the Arduino MEGA 2560.inf driver. At times it seemed to freeze my mouse. I have now set it to use GDI+ which seems better in that I can move my mouse more easily, but clicking is slow to react. 

This reply was deleted.


DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Drones via Twitter
Jan 14
DIY Drones via Twitter
An improved version of the Intel OpenBot https://ift.tt/2KkHT8Q
Dec 14, 2020
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16, 2020
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10, 2020
DIY Drones via Twitter
Getting started with Robocars https://ift.tt/2HWsudU
Nov 1, 2020
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20, 2020
DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
Aug 3, 2020
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
Aug 3, 2020
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
Aug 3, 2020
DIY Drones via Twitter
RT @davsca1: Here is the video of the performance. This paper was a huge group effort and more than one year of work, where we combined and…
Jul 16, 2020
DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Jul 7, 2020
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Jul 6, 2020
DIY Drones via Twitter
RT @chr1sa: Here's today's best times in the @DIYRobocars/@donkey_car virtual race of AI cars compared to last month's race on the same tra…
Jun 20, 2020
DIY Drones via Twitter
Jun 19, 2020