I'm using Planner 1.1.14 with a new APM2 board. Win XPpro and the Atmega2560 inf driver file from the repository.

Planner loads and verifies the 2.27 firmware but it does not connect to the APM2.  I have used Putty and it does reset the APM2 on connect and I do see packets with mixed binary/alpha content (presumably MavLink).

When watching the APM2 board, it does not appear to come out of reset after Planner opens the port.  Since the reset step works correctly with Putty, it seems as though Planner is holding the reset line for some reason.

Should I add this as an "issue" ?

Thanks.

Views: 2074

Reply to This

Replies to This Discussion

Michael--  I just downloaded version 15 and tested it here.  Unfortunately it now seems to hold the APM2 in reset regardless of the state of Reset-on-Connect.  Planner 14 still works without Reset-on-Connect checked.

Yes, I spoke too soon. It worked for me the first time after a firmware upload, but not since. If I go into the Terminal mode, I can see that the board is initializing and MAVLink messages start flowing. But if I hit "Connect", it holds the board in a reset mode until timeout. This is with or without the "reset board at USB connection" checkbox checked. 

I am having this issue also with apm2.0.

I think it's something we can fix with the Mission Planner. Affected boards we've seen only freeze up when the Mission Planner tries to connect via USB. No problems over Xbee, MAVproxy or other desktop software over USB.

in the planner config > planner. is "reset apm on USB connect" checked?

ill upload a new planner in the next 10 mins or so that hold the reset line high, instead of low like at the moment.

Just tried version 16.  The APM2 connected regardless of the Reset checkbox state.  It did appear to do a restart though.  Is that correct?

I think that's it! Just tried a half-dozen times and 1.1.16 reliably connected every time for me. Many thanks, Michael. 

For me the new mp fixes the problem for 99% I still have sometimes the MP won't connect and the lights won't flash. After taking power off en puting power back it will be fine again.

Hi Michael,

While 1.1.16 works much better, I did have an incident yesterday which indicates to me that there is still the scope for problems. Having refitted my sonar, I wanted to have a clean install, so erased the EEPROM from the CLI and then did a reload of the 2.1.0 Alpha firmware. I noticed at that point that the Wait was indicated as 17 seconds, although it felt longer. When I went to APM Set Up (Plane and Quad), I could not connect - it indicated to me that there was no firmware. I reverted to 1.1.14, reloaded the firmware, 90 second wait this time, but still could not connect. At this point, I stated panicking! Eventually, after rebooting my computer, it started connecting ok.

this will be to do with the 90 sec / 17 second issue. as the current firmwares still actualy require 90 seconds. the trunk code only requires 17 seconds to do the reset.

 

the fix is.... wait 2-3 mins after flashing the code, and dont connect in that time. and it will fix itself.

We'll be pushing an ArduCopter hex in the next day or two that will bring the trunk code public and resolve this issue. 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service