Unable to retrieve logs

Hi Guys

I'm pretty new to APM2, so don't be surprised if I missed an obvious step.

However, I set up my APM2 and was able to go for a flight (not without some issues, but at least I got Loiter to work on my ICON A5 while flying off the water).

I want to retrieve the logs from the APM2.  In MP 1.21 mav 1.0, I go into terminal and log download, but I get 'error opening com port'.   While the icon in the upper right shows it as not connected, the terminal actually is.

Show settings works as does tests and radio setup.  It is just the Log Download that doesn't work.

If I go into the CLI, I can see the logs and dump them (I am trying to figure out how to actually capture the dump).

Any ideas?

Mike

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have the same issue.  If unplugging and replugging the APM2 does not solve it.  I close Mission Planner and try again.  I am not sure but I think Kasperksy virus protection plays a role.  In the worst case, I reboot the computer. 

  • I'm getting the same error "Error opening comport" if I already connect mission planer with APM2 (through 3DR radios) but if I don;t connect first, and just hit log download you can see what is happening in the link bellow, I waited about 10 minutes but no logs appear in that list :(

    http://prntscr.com/i93yo

    I tried Per Elofson's solution but dod not worked either. Also an intresting note at least for me, while the Log Download window is opened in the Link Stats window the quality drops to 0 or NaN and also lost packets start increasing, like in the screen show bellow

    http://prntscr.com/i94q5

    In the bellow screenshot the Log download window is closed and the link seems to work just fine 

    http://prntscr.com/i94wp

    PS . I instaled the latest firmware a few days ago, 2.8 but don;t know if this is an issue with APM2 or with mission planer as bouth ware updated recently. It;s been a month or so in wich I did not used my copter, but now a week I received a few parts and started again playing with it.

  • I'm having the same issue,

    " 'error opening com port'.   While the icon in the upper right shows it as not connected"

    I just updated to 2.5 and it worked before that.

    I just tried another approach:

    Unplug USB

    Start Missionplanner

    Navigate to "Terminal"

    Connect USB

    Press "Connect"

    Press "Log download"

    That worked for me.

  • I am also new to all this APM stuff, and sometimes have a similar issue. What has worked for me is to unplug the USB cable from the laptop and plug it back in. Seem that the mission planner gets confused about the connection sometimes when going to the terminal screen.

    Also, I sometimes seem to have problems if I plug the USB in the computer first, seems to work better if the cable is connected to the APM first.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Friday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…