Moderator

Unable to update ATMEGA 32U2 PPM Encoder with FLIP

I need a bit of help here, I am attempting to update the PPM encoder on my APM 2.5 following the instructions here in the Arduplane Manual.

I have downloaded and installed Flip 3.4.7.112 using all the default settings and have connected, shorted, and reset my board as per the instructions. When I attempt to connect to the ATMEGA 32U2 device via USB I get the following error messages:

3691000173?profile=original

3691000128?profile=original

I've tried a reboot and I have tried uninstalling the program, re-booting and re-installing but I keep getting the same error.

For the record I have tried both the download link in the instructions from the drop box (link is broken at this time) and I have downloaded it direct from the Atmel web site (same file). I am using a Windows 7 Professional 64-bit machine and have checked all my drivers and updates.

Anybody got any suggestions?

Nathaniel ~KD2DEY

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I've been dealing with this for days.. It all started when I tried to install new firmware via APM Planner 2.0.18 and it told me it couldn't contact the bootloader. Subsequent googling led me to forums with information similar to this one.

    I've tried Ubuntu 14.04, Windows 10, OS X 10.11 and even a couple of virtual machines to get rid of "AtLibUsbDfu.dll not found." So far no luck.

    In device manager all I get when I "reset" the ArduCopter (by connecting the two pins w needle nose pliers) is the sound of a usb device being disconnected and "Ports (COM & LPT) > USB Serial Device (COM3)" goes away. When I remove the pliers that same device shows up again, nothing changes with flip because I still hear that the dll is not found. It's troubling that I don't even see the ATMega device. Maybe my board is fried.. Any ideas?

  • I have the same problem with Windows 10 64bit...
    But windows tells me that it has the best driver and will not let me replace it.
    Anyone know how to fix Windows 10's drivers.

    error message:

    The folder you specified doesn't contain a compatible software driver for your 

    device. If the folder contains a driver, make sure it is designed to work with

    Windows for x64-based systems.

  • I can't get it to work on 64-bit.

  • Hi,
    Even I followed the same procedure, but in FLIP, my apm is not connecting to the software and also I checked in device manager but there is no other devices and also there is no "ArduinoMega 2560 DFU" option. I rechecked all the connections but I got the same problem. please help me to solve this problem.
    Thanks.
    • i got the same issue.

      following the way that how to get  into DFU mode. device manager only print  "ArduinoMega 2560".

       there is no "ArduinoMega 2560 DFU"

      I have two boards and both them get the same problem.

      someone help, thanks.

  • Moderator

    OK for anyone who is interested I figured it out and was able to update the eeprom. What you need to do is update the device driver AFTER you boot the APM board and install the jumper and reset the Atmega32U2 (as per the instructions).

    3692635083?profile=originalRight click on the ArduinoMega 2560 DFU and select 'Update Driver', browse to the location where your FLIP application is installed and find the 'USB' folder. For me that location was 'C:\Program Files (x86)\Atmel\Flip 3.4.7\usb'. Now click 'Next' and complete the update of the device driver. This may take a moment so be patient. Once it successfully competes follow the instructions for updating the PPM encoder here.

    Once everything is working you should be able to connect via usb and see a screen like this:

    3692635184?profile=original

    Then after the update:

    3692635204?profile=original

    That's it no big deal! We might want to update the instructions for updating the PPM encoder to reflect this step updating the device driver.

    Nathaniel ~KD2DEY

    • I'm pretty sure this has to be in 32bit of windows. I can't get it to work in Win 7 64-bit. So I'm installing XP 32-bit in order to get the driver to work.

      Pain in the butt.

  • MR60
    Hello,
    This error message happens because you are using win 64 bits and flip has published a known bug on 64 bits. There is a workaround on the site of flip but i do not remember what that is.
    Or alternatively upgrade from another PC which does not run a 64 bits version.

    Cu
    Hugues
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…