It seems since going to 2.7 and up to 2.73 I am having uncontrollable glitches with the motors. I think I have isolated everything, no bullet connectors, checked the amperage draw of the 880 motors to see if bearings could be the problem.I have 2 units, TriHex & Octo with 1 inch carbon fiber tubing for the arms, exhibiting the same glitches, I don't know what's causing it. This morning I flew the TriHex for about 10 seconds and about 5 feet high and suddenly it rolled completely over upside down all within less than a second and broke 5 props, anybody else having this problem or a solution. I'm not flying anymore until I have a fix.....I see 2.74 is in the works but don't see anything that would fix this....Don

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • For me, the random ESC blips (very brief duration pulses) clearly do stop occurring when I give CH6 a low value, and they are easily reproducible when I flip a 2-pos switch on my TX to give APM2-CH6 a high value.

    However, I now have a new problem. It is a random, less frequent, more sustained uncommanded pitch/roll, which caused two crashes so far.

    The very quick glitches that I previously had never caused me to crash because the quad always quickly returns to level. But the new misbehaviour is more dangerous. It is like a loss of control. I will need more tests to trace the cause... I can't be sure if the APM2 is to be blamed for this.

  • Hi,

    We just fixed our own motor glitches and twitches problem after some time. The culprit was the multi-connector cable between receiver and APM board. They were probably a bit worn and if there is some vibration, they loose contact. An observation though, this same connector works well with the AQ50D FC. Possibly, less filtering of input noise/glitches or more noise sensitive inputs in the APM. Hope this helps those who are having the same problem. 



  • When I had the problem, it was spiking without the batteries connected also.
    Does it spike on the bench, no power to the ESC?
  • I had a look into the logs...
    3692547647?profile=originalFirst part is with aux3 set to minimum.
    At line number 1400 I turned aux3 to maximum and the motor spikes appear.

    Around 2200 I cut the throttle and set aux3 back to minimum, throttle up --> no spikes

  • Interesting,
    I had a problem with all four motors pulsing and then it went away. The only change I made was to remove ch 6,7 and 8 connection to the RX.
    I haven't had a chance to investigate further but this makes sense.

  • Additional tests...

    I removed aux3 (AR8000) and hooked up aux1 and aux2 of the AR8000 to ch6 and ch7 --> No glitches
    Put aux3 (AR8000) to ch7 and turned aux3 tot maximum --> glitches.

    Is there something wrong with the ppm encoder on the APM2.5?

    I also have an APM1 where I use the same receiver and same setup (aux3 to ch6) without any problem.

  • Hi Don,

    Had exactly the same behavior.
    Tried to narrow it down by taking my quad apart completely as I needed to find the cause.

    My setup:

    Board: APM2.5 (2.8.1 firmware)

    RX: AR8000 (DSM2)

    ESC: 20A Hobbyking blue series (SimonK flashed)

    Motor: 2212 - 850KV

    Lipo: 3S 2200mAh

    Bec: 3A Turnigy at 5V

    Took out the board, hooked up to RX and one motor to ouput1.
    To make sure there was no vibration as cause the board and motor were separated.

    Even used separate power source to power the board and motors
    Even with all taken apart still glitches.
    So as the RX was the only thing left and possible cause.

    RX setup set as described in the manual for basic channels

    ch5 - Gear (AR8000) mode

    ch6 - Aux3 (AR8000) knob to be able to tune in parameters

    ch7 - Aux1 (AR8000) function to be defined

    So I removed the connection between aux3 on the AR8000 and the ch6 of the APM2.5

    The glitches were gone!!!!!!! Very, very strange.

    I tried it at least 5 times to be sure.
    Haven found this I started looking further and found that when aux3 (AR8000) is at maximum you will have glitches.
    When you put it to minimum, no glitches.

    It is very unfortunate not being able to use aux3 (knob) on the DX8 as it is very handy to dial in the tuning values.
    To be sure nothing is wrong with the RX I hooked up another AR8000, same behavior.

    At this moment I do not have an explanation for this but if someone who has the same behavior could test this, it would be nice and if someone finds a cure for this it would even be better :-)

  • Now that Arducopter 2.81 is out, I decided to take this chance to document the glitching again on 2.73, then upgrade to 2.81, then check for glitching again, for the sake of comparison.

    Unfortunately, (by my unscientific tests), the glitching problem appears to be the same or worse in the new 2.81 compared to 2.73.

    Video of the glitches on 2.73:

    Video of the glitches on 2.81:

    Actually, you'll have to listen to the abrupt blips in the motor whine. The glitches aren't actually visible.




  • Here are videos showing my APM2.0 with 2.7.3 quad firmware, glitching:

    On the ground:

    In hover (1 of 2):

    In hover (2 of 2):

    With the APM2 isolated from frame vibrations:

    This is evidence strongly suggesting that the twitching CANNOT BE BLAMED ON VIBRATIONS.

  • Hi, I have the intermittent ESC blips on my APM2 (on current quad firmware 2.7.3) too.

    They are quite easy to reproduce during low throttle, (make small cyclic stick movements esp. with roll&elev together, i.e. diagonals.) and seem to almost never happen during higher throttle levels.

    The blips / twitches / glitches did occur in flight too, the quad would make a quick bank and quickly back to level again.

    I will try to shoot and post videos when I can.

    I have tried to check if it was a motor/ESC problem, so I tried connecting each of four ESC-motors one-by-one. And for each ESC-motor, I tried it in all 4 motor outputs of the APM2, the result is that I could get the blips in ALL cases. This tells us it is very unlikely to be ESC/motor related.

    Then I recorded some telemetry, and graphed the "servo outputs" and "rc inputs". (see attached tlog file) And checked for spikes. The largest spikes were not commanded by the RC.

    My APM2 (in plastic case) is simply cable-tied on to my GF frame with a little grippy-rubbery mat. But I don't think my vibrations are too bad, I did statically balance my props and I get nice stabilization and flight characteristics, except for the blips. I will test the possibility of vibrations causing the blips by removing unfixing the APM2 from the frame and maybe handholding it while running my low-throttle tests. If the blips still happen, then I think I can rule out vibration as a cause.

    2012-10-13 21-20-53.tlog

    2012-10-13 21-20-53.rlog

This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
Benewake LiDAR liked Benewake LiDAR's profile
Apr 12
Gremsy liked Gremsy's profile
Mar 12