Unexpected motor glitches (speed up) with Tri Hex and Octo APM 2 & APM 2.5 using 2.73

It seems since going to 2.7 and up to 2.73 I am having uncontrollable glitches with the motors. I think I have isolated everything, no bullet connectors, checked the amperage draw of the 880 motors to see if bearings could be the problem.
I have 2 units, TriHex & Octo with 1 inch carbon fiber tubing for the arms, exhibiting the same glitches, I don't know what's causing it. This morning I flew the TriHex for about 10 seconds and about 5 feet high and suddenly it rolled completely over upside down all within less than a second and broke 5 props, anybody else having this problem or a solution. I'm not flying anymore until I have a fix.....I see 2.74 is in the works but don't see anything that would fix this....Don

Views: 3838

Reply to This

Replies to This Discussion

Do you have any logs? 

I have been testing without connecting, let me do a short one and I will attach, thanks for the reply....Don

Please enable Motors and RAW in the Flash logs too.

Here is my test a few minutes ago, right towards the end the motors really started glitching, thanks....Don


Would you also have the onboardflash log as well?

Not sure what that is....Don
Would it be in my logs....Don

go to the serial window and enter the CLI. You should type "logs" then "dump 20" if 20 was the highest number available. 

The ground station has a log dump utility as well.


Ok I did that, after that it says
Bad log number

24 logs
Log -23452'. Start 1, End 1
Log -23451, Start 1, End 1

Not sure what that means....Don

you can just type dump and grab the whole lot.

Then erase the logs.


Hi Jason,
I flew the Octo twice this morning, each ten minutes and it worked perfect, there may have been one slight glitch during the first flight, but may have been my imagination.
What I don't understand what dumping the logs has to do with it, or does it, thanks.....Don

I have found that when my quad does not 'behave' regarding the motors, an 'DISARM' followed by an 'ARM' seems to clear it up.

For example: last week on flight #12... Initial start up and GPS lock was achieved. I ran the throttle up and the quad essentially lifted 3 legs and started to rotate in a yaw direction on the 4th leg! I throttled down then up, same results. The motor on the 4th leg was spinning but obviously not at the same RPM as the other 3. I pushed throttle farther and it got off the ground and immediately did about a 270 degree yaw and stopped. Throttle down to land. Same result on the 3rd throttle up.

At this point I disarmed, armed, and the behavior returned to 'normal' and I ran the battery down having fun.

I am going to look over the *.log file in a bit to see if there is something obivous (been repairing a crashed CP heli - another story for another time).

Jasonshort - I cannot find in the Wiki how to enable the Motors and Raw for the dataflash logs. This has been suggested in many discussions. It also does not appear with a '?' command in CLI under the logs section. It is probably hiding in plain view.


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service