Solved by changing PC and USB port. 4 of 6 ports caused this error.

Mission Planner 1.2.53 (latest)

APM 2.5.2

OS: Windows XP

All drivers downloaded, installed and checked just before the test. APM moved to COM4.

After uploading different firmwares got this message: "upload succeeded but verify failed", each time with different byte addresses. Tried on two laptops with total of 6 usb ports. Only 2 ports continuosly upload without errors. Others fail.
 They fail only in MP upload. Mouse and generic Arduino uploads appear to be flawless.

I think this behavior must be noted in the manual so users will have in mind that they better have more than one computer on hand before working with Ardupilot.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    this will be a usb power issue, or linked to the usb cable being used

  • Same thing just happened to me.  I haven't tried pushing it via Arduino yet, but I'll be glad to give it a shot.  Never heard of mouse... is that another programmer?  Briefly searching for it didn't reveal what I was hoping to find lol

This reply was deleted.