Hi,

first up - my problem is with an APM 2.5 clone (arduflyer) - I know some of you don't want to assist with hardware not bought from 3dr store (which is fine) so I'll make this point clear at the beginning so you can stop reading. 

If you're still reading.

I'm experiencing connection problems with my APM 2.5 clone.

Some background: I received it a few days ago, connected it to the latest version of mission planner without problems and loaded 2.9 firmware on it (for Hexa). Did acc & compass calibration, radio calibration, GPS and telemetry modules. Everything seemed to work. After reading some reports of people experiencing problems with 2.9 I decided to downgrade to 2.8.1. before setting up the motors etc.

Did the downgrade and a reset. Everything seemed to work.

Then I did a few more bench tests the following day. I connected 5V from a UBEC to the board and connected  from Mission Planner  via the 433 Mhz telemetry radios. This seemed to work. Then I connected the GPS. This also worked but I received quite a few error messages such as "Parameter XXXX already set" (for different parameters XXXX) and eventually a connection error.

I tried this a few time with and without GPS with varying success. I ended up having the arduflyer board with just the radios on my desk and I could connect and disconnect successfully on a few occasions. Sometimes I would get the "Parameter XXXX already set" errors. After one of the tries where I received these errors I clicked on disconnect and then on connect and I didn't get a connection anymore. After a while I got a timeout saying that no Hearbeats had been received.
I clicked connect a few more times - same error. Note that the 433 MHz radio LEDs indicated that the radios were connected.

Then I tried to connect again via the USB cable. No success - same error. I haven't been able to talk to the clone board since. When I plug it into the PC it shows up as COM 4 Arduino 2560. However, I can't communicate with it through Missionplanner or the Arduiono IDE. I can't upload new firmware using MP or any sketch with Arduino. CLI in MP also doesn't work. When I try to initiate USB port communication with the board it appears to reset (LEDs A and C flash rapidly a few times, then do cylic flashing for a few seconds and finally the red LED blinks slowly).

I spent quite a bit of time reading here and elsewhere and found some threads with similar but not identical issued. I've reinstalled Mission Planner, USB-Serial drivers etc. to no avail.

Based on how it happened I am almost 100% confident that I didn't fry the board by connecting something wrongly (reverse polarity or too high voltage). I think the error is something more subtle - either a flaky component or some software problem.

If it is a hardware bug I suspect it is somewhere in the Auto-MUX circuit that switches between USB and radio telemetry.

Otherwise, could I have somehow "killed" my Arduino bootloader through a software bug? I don't see how but I do have an USBAsp AVR programmer at hand and I could try reflashing the boot loader.

I also contacted the vendor (only a couple of hours ago - so wouldn't expect a response yet) but even if they offer to fix it - due to shipping times from and back to Europe I'd vastly prefer it if I could somehow diagnose and fix this myself in the coming days. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Did you get a resolution? I think I have the same problem....

    My APM 2.5 (from RCTimer) is very new and I have flown it in my Bixler2, tested Stabilise, Loiter & RTL.

    Finally did a mission today and all worked fine until I tried to download the logs.

    Now I cannot communicate via USB or by 915Mhz module, but I could earlier the same day! (both ways)As I cannot reach CLI / Terminal window, I cannot reset the board.

    I am running at the correct baud rates, because some of the text is readable eg: ArduPlane 2.7b comes up but the 3x Enter keys do not work.

    Graham

  •  

    worst day of my flying "career"

     

     

     

    I had an ESC wich wouldnt start due to the outside temperature.

     

    Yesterday was a beautiful day to test the new software for my APM2.5. So I went outside, and the darn ESC acted up again. So I hurried back inside to exchange the ESC for another one. That took me a few hours because of my construction.

     

    When I switched on the copter, I saw a tiny stream of smoke. At first I thought it was a hair from the cat floating into focus, but it wasn't. After that no communiction with USB anymore. The system is still alive, I get GPS lock The RX/TX leds blink when communicating with something else than the USB port. But I dont have PPM anymore and no USB. I think the USB input of the atmega32u2 is fried. Now for a way to desolder and resolder a new chip.

     

    The cause of my trouble was a faulty, NEW, speed controller. The voltage out of the BEC was 8.5V and fried (only) the atmega 32U2?

     

    I still dont know where the smoke came from, which wouldt make it easier to repair the APM.

     

    The 2 VDR's on the input of the USB port are still ok, as are the two fuses.

     

    I didnt check the zener yet but I think it will be ok also.

     

     

     

    In the meantime I have ordered a new APM2.5 board, this time in china, because 3d-robotics is too expensive, and they send you a box (which weighs 20 grams) with the price on the outside, so dutch customs hits you with an additional very expensive tax. (why Oh why not send it in a closed envelope!!)

     

     

     

    Bye for now,

     

    a very sad Wilfred.

  • Try going back to 2.9, might be a change to the latest MP (that 2.8.1 doesn't like).

    woops, read half your post.. my guess is you wiggled something loose on one of your connectors.

  • Moderator

    Have you tried USB with the radios unplugged?

  • Admin

    @OpticalFlow,

    You will probably not get much sympathy here. Most of the cloners probably use the cheapest parts and processes that are available to maximize their profits. Quality control is everything and you are probably a victim of the lack of it by the cloner you bought from.

    Just a thought.

    Regards,

    TCIII

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…