Wireless telemetry set up but not communicating with Configurator

I can use the X-CTU app to read the modem's parameters but when I open the configurator it just keeps trying to connect but never does. As long as it's trying to connect, the red light comes on the xbee plane side. What is the red light indicating? Also the orange lights on both flicker so it seems the are communicating but I can't get any activity in the configurator program. I've chosen COM5, 115200, and 30 second time out.

Is there some test I can run? I tried the ones on this page but didn't get any results. I tried using the serial monitor in Arduino 0021 but didn't get any response. Can I just put Serial3.print() and press send? I'm using carriage return in the popup and 115200.

http://code.google.com/p/arducopter/wiki/Quad_TelemetryPage

Views: 799

Attachments:

Reply to This

Replies to This Discussion

"The Xbee modules ship with a default of 9600bps, which you must change to match the APM's serial speed of 115200bps; set your Xbee modules to match this speed."

have you done this?

 

what is the response on the 'S' command?

Yes I've done that and can plug both into the USB cable and can READ the data using X-CTU. So I can communicate with them via USB when they are both in master mode but when I put the one into slave mode and connect it to the APM then I see the red light come on the slave as it's trying to communicate with it but it just keeps retrying and never succeeds. When I connect via USB directly to the APM then I see the activity in Configurator fine.

BTW, I'm using these boards.

http://store.diydrones.com/product_p/br-0015-01.htm
have you enabled telemetry in arducopter code?
@F11...I had the same red light on my xbee. You need to enable this line in the arducopter code on the ArducopterNG tab>>>      #define SerXbee
This is what I did to enable it but it still has the red light on.


////////////////////
// Serial ports & speeds

// Serial data, do we have FTDI cable or Xbee on Telemetry port as our primary command link
// If we are using normal FTDI/USB port as our telemetry/configuration, keep next line disabled
#define SerXbee

// Telemetry port speed, default is 115200
//#define SerBau 19200
//#define SerBau 38400
//#define SerBau 57600
#define SerBau 115200
try to switch both modules to master and try again
You have to switch to master when uploading new code to the APM? Then switch the plane side one back to slave?

Does it work in other baud rates (like 57600)?

 

Try setting the baud rate in the code to 111111. 

#define SerBau 111111

I had a similar problem, you can read about it here:

http://diydrones.com/forum/topics/strange-behavior-with-xbees?xg_so...


why do you switch back to slave?^^

I don't have those Breakout boards from DIY, just 2 similar without switch from Sparkfun (just like both are master) and it works without any problems

You should not switch to slave, but leave both on "Master.

Because I'm a noooob :) I have it now to master master and it's working beautifully!!

The flight is very stable if there is no wind. With light wind it is a fight to keep it where you want it but I'm sure that is normal. What is the max mph wind it can normally be flown in without a lot of difficulty?

I'm getting 16 minutes on Turnigy 5.0 20-30C batteries. I got the kit with the larger motors.

Arm 28cm
Motor AC2836-358, 880Kv
Propeller set, 12x45 EPP Style, Black

After flying those toy mini helis with 2 props, it is tricky to get use to the yaw on the left stick with the throttle. I will need to practice with a simulator.
Any suggestions on how best to set the transmitter for easy flight? I have a JRX9503. I'm getting a good hover at about 50% throttle but wondering if I should define some curve to make the throttle feel better limit it to some max to avoid turning it into a rocket :)

Are there any plans from the ardupirates to implement a carefree mode using the magnetometer so you don't have to worry about which is the front of the craft? I find it very easy to get disoriented and will add some colors to the arms to help but a carefree mode would be much better!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service