I can use the X-CTU app to read the modem's parameters but when I open the configurator it just keeps trying to connect but never does. As long as it's trying to connect, the red light comes on the xbee plane side. What is the red light indicating? Also the orange lights on both flicker so it seems the are communicating but I can't get any activity in the configurator program. I've chosen COM5, 115200, and 30 second time out.

Is there some test I can run? I tried the ones on this page but didn't get any results. I tried using the serial monitor in Arduino 0021 but didn't get any response. Can I just put Serial3.print() and press send? I'm using carriage return in the popup and 115200.

http://code.google.com/p/arducopter/wiki/Quad_TelemetryPage

arduino.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have two Xbee Pro Series 2 2.4

     

    Which function set i have to set ? [ ZNET 2.5 ROUTER/END DEVICE AT ? 1247 ]

    One connect IMU with diydrones adapter and one connected the computer with sparkfun USB explorer.

  • I encounter the similar situations as you on the RC1 code. The ground Xbee (sparkfun adapter) will have TX led blinking and the Airborne Xbee  (diydrone adapter) will have the RSSI (red)led lit up. The configurator cannot connect to the APM.

     

    Later, discovered that using the USB connect to the APM+oilpan to configurator also failed. Then comment the IsXBEE and reload the code RC1, then able to connect to configurator using USB.

     

    Anyone encounter failling to connect to configurator using USB when uncomment the IsXBEE in RC 1 code?

  • Any suggestions on how best to set the transmitter for easy flight? I have a JRX9503. I'm getting a good hover at about 50% throttle but wondering if I should define some curve to make the throttle feel better limit it to some max to avoid turning it into a rocket :)

    Are there any plans from the ardupirates to implement a carefree mode using the magnetometer so you don't have to worry about which is the front of the craft? I find it very easy to get disoriented and will add some colors to the arms to help but a carefree mode would be much better!
  • Because I'm a noooob :) I have it now to master master and it's working beautifully!!

    The flight is very stable if there is no wind. With light wind it is a fight to keep it where you want it but I'm sure that is normal. What is the max mph wind it can normally be flown in without a lot of difficulty?

    I'm getting 16 minutes on Turnigy 5.0 20-30C batteries. I got the kit with the larger motors.

    Arm 28cm
    Motor AC2836-358, 880Kv
    Propeller set, 12x45 EPP Style, Black

    After flying those toy mini helis with 2 props, it is tricky to get use to the yaw on the left stick with the throttle. I will need to practice with a simulator.
  • You have to switch to master when uploading new code to the APM? Then switch the plane side one back to slave?
  • This is what I did to enable it but it still has the red light on.


    ////////////////////
    // Serial ports & speeds

    // Serial data, do we have FTDI cable or Xbee on Telemetry port as our primary command link
    // If we are using normal FTDI/USB port as our telemetry/configuration, keep next line disabled
    #define SerXbee

    // Telemetry port speed, default is 115200
    //#define SerBau 19200
    //#define SerBau 38400
    //#define SerBau 57600
    #define SerBau 115200
  • Yes I've done that and can plug both into the USB cable and can READ the data using X-CTU. So I can communicate with them via USB when they are both in master mode but when I put the one into slave mode and connect it to the APM then I see the red light come on the slave as it's trying to communicate with it but it just keeps retrying and never succeeds. When I connect via USB directly to the APM then I see the activity in Configurator fine.

    BTW, I'm using these boards.

    http://store.diydrones.com/product_p/br-0015-01.htm
  • "The Xbee modules ship with a default of 9600bps, which you must change to match the APM's serial speed of 115200bps; set your Xbee modules tomatch this speed."

    have you done this?

     

    what is the response on the 'S' command?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
DIY Robocars via Twitter
RT @chr1sa: We've got a record 50 teams competing in this month's @DIYRobocars @donkey_car virtual AI car race. Starting today at 10:00am…
Nov 7
DIY Robocars via Twitter
Nov 6
DIY Robocars via Twitter
RT @a1k0n: Car's view, using a fisheye camera. The ceiling light tracking algorithm gave me some ideas to improve ConeSLAM, and having grou…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: To get ground truth I measured the rug, found the pixel coordinates of its corners, calibrated my phone camera with my standard…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: @DIYRobocars is back in December, but outside. Time to reinvestigate ConeSLAM! I rigged up a quick and dirty ground-truth captur…
Nov 5
More…