HELP

I bought a XUAV Talon with wing extensions in 2015 and still haven't been able to fly it using waypoints and using the RTL. I am able to fly it manually.

The radio is set up with Manual, FBWA and RTL

Pixhawk with the latest Plane3.7 and Mission Planner

I have flown it manually and according to the MP, it will fly in a circle if the radio is turned off. Ground tested.

If I switch to FBWA it flies fine and stabilizes accordingly.

If I switch into RTL on the radio, it dives for the ground and the throttle increases.

Does anyone have the parameters for this as this has been most frustrating and I have been wanting to use the waypoints and fly it with confidence. My radio has been set up (T8FG) and it all seems to work with the plane, but for some reason, I cant fly waypoints and I am worried that if I lose signal, it will crash.

Look forward to some help.

Views: 1119

Reply to This

Replies to This Discussion

A log would help.

Diving and speeding up is a symptom of the plane sensing it's going too slowly or it's altitude is wrong or possibly tuning. Incorrect airspeed sensor placement/setup can cause this as well as wrong speed parameters but there are many reasons why it would do this. Flying FBW-A is good as it'll prove that the plane can fly OK but you're controlling throttle, however FBW-B uses throttle as well and will show up problems by adding the throttle to the mix.

I usually use LOITER as the next step after FBW-A as that will show if the plane is capable of maintaining a course around a point. If the plane dives on the downwind leg then you need higher pitch_P as a start.

Agreed.  I'm guessing the plane is flying below the specified cruising speed (TRIM_ARSPD_CM) when he enables an auto mode and is diving to speed up.

Hi Graham and Scott

Tx very much for replying so soon.

Unfortunately I reset the pixhawk completely yesterday and so would have to do another test run, which I will do and post the log.

I am still new at this Pixhawk/Mission Planner as I have been using DJI in the past, but have been learning much to do with all the setups etc....but still missing things....

Having looking at the parameters I have setup, my TRIM_ARSPD_CM = 1600cm/s

My plane was flying at about 60m above the ground at about 11m/s. I will look into this.

You don't by any chance have already setup Talon parameters that I could upload and fine tune to my settings.

The other thing I am not sure about is my override to the safety switch as my switch broke, Not too sure if this would have an effect.

Really appreciate your help

do not use someone else's param file. it may not work. jsut check for the PID for roll2srvo and picth2servo and NAV2prd from the wiki documents and create your own params for other items.

these are my parameters.

Maybe someone can help me on this?

Attachments:

Mine works well with return to home
the only thing i can see that you have different than i have is 

param                 Mine yours
VTAIL_OUTPUT    2      3
RC2_REV              1     -1

and i don't use the air speed sensor

all the parameters of the airspeed are different
have you tryed to plot gps speed against airspeed ? mine follows quit well


try to disable the airspeed sensor and see how it goes

A clue also might be that you said your TRIM_ARSPD_CM = 1600cm/s yet your plane is flying at 1100cm/s (11m/s) so that parameter is set at least 5m/s too fast.

Hi Ravi

Thanks for your reply, I do understand that one must not use someone else's parameters, but just wanted to compare.

I will look at the pids.

Much appreciated
 
Ravi said:

do not use someone else's param file. it may not work. jsut check for the PID for roll2srvo and picth2servo and NAV2prd from the wiki documents and create your own params for other items.

Hi Martin

Tx for your feedback. I will look at these parameters and see if it makes a difference.

I haven't been able to test anything regarding waypoints yet as it hasn't worked after uploading the waypoints.

When I add the waypoints, the MP says they are uploaded but when I fly and switch to FBWA nothing happens, and yet I can fly in FBWA and use the radio to control the flight.
 
Martin Guttesen said:

Mine works well with return to home
the only thing i can see that you have different than i have is 

param                 Mine yours
VTAIL_OUTPUT    2      3
RC2_REV              1     -1

and i don't use the air speed sensor

all the parameters of the airspeed are different
have you tryed to plot gps speed against airspeed ? mine follows quit well


try to disable the airspeed sensor and see how it goes

Tx Graham, I will be changing this parameter to see what happens on the next flight and will revert
 
Graham Dyer said:

A clue also might be that you said your TRIM_ARSPD_CM = 1600cm/s yet your plane is flying at 1100cm/s (11m/s) so that parameter is set at least 5m/s too fast.

to fly waypoints you have to use AUTO mode 

Hi Martin

WOW....?????!!!! I bought the plane and asked that it be set up to fly waypoints specifically. The guy (no name mentioned as he is a member and owns a shop) who initially set it up said that it was all set up to do that and all I had to do was switch into FBWA????? He claims he tested it as well and it worked with my RC. My problem is he is never easy to reach and he is about 500km away from me. I am new to all this and I am annoyed now. Thank goodness I have 30 years of flying but no experience in the Pixhawk setups, hence I have been able to test it in the air without a problem.....thank goodness

 I asked this "guy" who does work with his planes and he does surveying using drones etc and uses the Pixhawk, and you would have thought he could have told me this or set it up correctly. He has replies to many issues on the blogs. One questions his integrity then. 

Tx very much Martin for informing me. I will try and set this up now.
 
Martin Guttesen said:

to fly waypoints you have to use AUTO mode 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service