Yaw and Throttle mixed up

I always try to search through all forums before asking but this time I am completely baffled. First Im using an APM2.7 and arducopter 3.1.5. After a crash I reconnected everything as they were since apparently they weren't damaged. I recalibrated everything but when I got to radio calibration, the strange thing is that moving yaw stick right actually moves throttle up in the calibration page. And moving throttle stick up actually moves yaw left. I checked the 9xr pro tx and everything was as is before. All leads from apm input to orange rx are correct meaning input 3 is throttle on the rx and input 4 is ele on the rx. So I reversed the leads for both and the radio calibration reads the stick movements correctly. But Im not comfortable with this change. Maybe someone has experienced this before? Is my rx the problem or the fc? Thanks for your time.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had this happen with an update to Mission Planner 1.1.29. An update to 1.1.30 set things back to normal for me.  Something to check anyway.

  • I tried using mixer to reassign channels but it wont arm or calibrate. I tried swapping the leads and even if calibration is okay when I plug in battery i get continouos beep errors.

This reply was deleted.

Activity

Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…