yet another motor arming frustration

I am trying to arm my motors using the standard left stick (throttle) move to the bottom and right. Nothing happens.

 

Configured arducopter using CLI running on a winxp machine.

 

Calibrated the esc without problem. Transmitter is communicating properly with receiver as motor tester menu successfully let the transmitter move each of the 4 motors in the right direction. Also CLI was able to calibrate minimum throttle value.

 

Loaded both arducopter and ardupirate codes but still unable to arm motors. Turnigy transmitter running on mode 2.

 

Looking forward to your assistance, thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Roger,

    I am having the same issue as you and read that you said the board was defective, were you able to get a refund at all?

  • Emile and Al,

     

    Tried your suggestions but no communication between arducopter and transmitter :( AND no communication between configurator, arducopter and  transmitter.

     

    To make sure its not a transmitter and receiver problem, attached a servo on each of the channel of the receiver and tried moving them via transmitter.No problem moving the servos.

     

    I know through the CLI that the roll and pitch transmitter stick (keft for my mode2) works. I have no other independent way of checking whether the throttle and yaw stick works when receiver is attached to the arducopter as no provision for said testing is available in CLI!

     

    Really stuck ... hellllppppp!

  • Hello!

    I'm mounting an Arducopter for a friend and I have similar problem. I already have one that works perfectly.

    I use configurator and CLI mode to config my Arducopter. I use mode 1 on a Futaba T7C and Fasst 2.4 receiver.

    When I use Configurator, I see that all sticks work perfectly. I did min throttle setup in CLI mode.

    When I try to arm motors (left stick down to right), nothing happens.

    I tried to put all his boards with the Fasst 2.4 on my Arducopter and it works perfectly ....left stick down to right and motors turn... The only things I had to do was to reduce throttle "Travel adjust" from 100 to 90 to arm motors..

    I don't understand anymore. Where is the problem. The only thing that is different is motors and receiver and radio. I have to say that we bought same ESC. Otherwise everything is equal.

    Can anyone help me ?

    Thanks

  • I had exactly this problem.

    In the CLI I selected "Reset to Factory Defaults" to wipe the EEPROM and ran through all the relevant CLI config options again and then after rebooting back into flight mode it started working properly for me.
    http://problem.In/
    See related links to what you are looking for.
  • Did you try the configurator to see if your transmitter moves the sliders in the TransmitterCalibration panel?

    To use configurator be sure to:
    1. Set your windows Regional Setting to English/US
    2. Be sure you have the Slider Switch to position 1 : http://code.google.com/p/ardupirates/wiki/Configurator
    3. Download and install from here (all files and libraries are included!) : http://arducopter.googlecode.com/svn/branches/Mikro/Configurator/Bu...
    4. Set the timeout to 30 secs.

    Once in the configurator do the transmitter calibration and see if the sliders move on your input.

    Hope this helps.
    Emile
This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…