FOLLOW ME / LEAD IT on Arducopter V. 3.x

I'm using Andropilot to control different platforms:

- Arducopter on APM

- Arducopter 32 on VRBRAIN

- MegaPirateNG on CRIUS AIO Pro

Ardupilot works great on all the platforms but Follow Me / Lead It functions seems to have problems with version 3.x 

On all the platform Follow Me was working perfectly on version 2.9 but with new version 3.x Follow Me is not working anymore: as soon as you activate follow me copter goes crazy and you need to switch back to manual control.

I've experienced the same problem on rel. 3.x on APM, VRBRAIN and today with MPNG the problem seem related to Ardupilot controlling Arducopter 3.x   

Is anybody experiencing the same problem?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Tested today FOLLOW ME with Andropilot and APMcopter V 3.2-rc2 and works great!

    Follow Me problems has been solved!

    Lead it interval=2 keeps copter very near the moving target (in my case an RC car running on the field) it's very OK!


  • Andropilot on board to an hexacopter controls "follow me" auto chasing of a DIY quadcopter with APMcopter 32 on VRBRAIN (v. 3.1.15)

    Chasing has some delay as in this first test lead it interval was set to 5 sec and speed to 5 m/s...

    ...but it works great!

  • FOLLOW ME problem has been solved in VRBRAIN arducopter32 code. Using this platform now FOLLOW ME works it was working before inertial navigation (before ver 3.x).

    These days I've done several FOLLOW ME tests with Andropilot without any problem.

    Code modification has been sent to dev team in order to be released to APMcopter and Pixhawk code as well.


    • Randy has closed the item. For APM and Pixhawk the fix will be included in 3.2!

      "A fix for the twitch when new position targets are set through guided mode is in master. This will bve on the to-be-tested list for AC3.2's first release candidate."

    • Just in time for summer.
  • It's not a FollowMe issue. It's Nav related. FollowMe is greatly affected, and the symptoms are more visible in this mode due to rapid position updates. Kevin had suggested changing the interval to 5 sec. which reduces the frequency of position updates, thereby reducing the effect. Copter is aggressively heading to it's next WP. The problem is that copter reaches this point, tries to stop there, and immediately has another WP that is relatively close to the last. The result is a seesaw effect. GO! STOP! GO! STOP! GO!
    If you were to plan a mission with WPs practically on top of each other I suspect the result would be quite similar.

    • I suspect you're right..
  • Kevin,

    I wonder if this can be a circuvention to this problem.

    I understand that when you set Follow Me Andropilot sends continuously a command to set GUIDED mode and new target coordinates to follow the GCS. If we could try to send new target coordinates only without setting every time  GUIDED mode (that can be set manually before starting follow me) perhaps we can have a follow me more robust, and we can deactivate it by rc changing flight mode...

    my 2 cents


  • I start to think that the issue is not just the follow me mode, but a incompability bug between Droidplanner & AC3.1 too.

    Yesterday I flew a Hexa (apm 2.5 AC3.1) and a Quad (Megapirate 2.9) with a tablet + Droidplanner 2.0 (Beta). The quad performs very well the Follow me and all the other Auto modes (Auto take off, landing, survey), but the Hexa with AC3.1 that flies great in Stab or loiter mode was a disaster...

    First the Follow me mode, some strange behavior when following me, the copter do not rotates to face next waypoint like the quad does (I don't know if it is a issue or a parameter not setted).


    So, the disasters...   First a complete mission (auto take off, 6 waypoints and auto land) with the Hexa. All worked fine less the last waypoint (land), so was manual landed. Second flight was a 6 waypoint in survey, the copter took off and flew to the first waypoint than sudenly dropped the altitude very agressively in a descend very stable but so fast that I was not able to recover the stab or manual flight mode. The result was many broken parts scratched on the ground, and the doubt why this happened.
    This last flight was not saved in the dataflash, and I don't know why too.

    The only thing that I know is that I don't trust anymore in Droidplanner + AC3.1 .
    • The problem is not related to V. 2.9. In V 2.9 Follow Me works great. The Follow Me problem is related to the new 3.x versions with inertial navigation. 



      here we are in Andropilot user Group. DroidPlanner is another app....but Follow me problem is the same :)

This reply was deleted.