Problem with initialization

Hi guys, I've a quadcopter with MegapirateNG 3.0.1 R4. I've connect with my quadcopter with AndroPilot before, everything was normal. But now, after an update, I'm not managing to connect with quadcopter, I connect the radio and it hangs on "Downloading Waypoints" and does not continue.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Yes I am also suffering connection issues with a new wifi only 8" galaxy tab. Sometimes works sometimes doesn't. Seems to be related to an Internet connection. The first time I tried it today it wouldn't connect, so I had to use my galaxy S4 instead which was fine. The second Flight I left the galaxy s4 wifi sharing on longer and then the galaxy tab connected and worked fine!

    Bug maybe?
  • Adding my own weight to the connection issue. Andropilot was working for me until last update, and it has not 'found the vehicle' since the update. That's via 3DR radio or direct USB.

    I loaded up Droid Planner 2 yesterday, and it connected first time and also every time. Andropilot still won't.



  • Power off and back on has been my fix for this new problem.

    • I have similar problem with Asus Nexus 7 first generation, APM 2.6 and RFD900. Restarting tablet have helped. Sometimes after reconnecting cables several times Andropilot connects to vehicle. Mostly I get message "No vehicle". Sometimes Android asks to close Andropilot.

      RSSI is fine and Andropilot gives message if modem is unplugged everytime so connection is established.

    • I have been getting the connection errors as well recently, in fact last night I had to use my Galaxy S4 phone (different operating system not KitKat) instead of the Galaxy 8" Tablet (KitKat OS) as it locked up every time.

      I have removed the anti virus software and tried it today without an issue, so not sure what the problem is as my phone runs the same anti virus software.

      I do use the phone to share the internet connection with the Galaxy Tablet when at a flying site and use my house WifI when at home, maybe that has something to do with it? Although it had been working fine until the recent andropilot update. Maybe something in that has been causing the issue?

    • I sorted out one method how it connects well, at least did five times in a row.

      1. Start Andropilot
      2. Wait
      3. when all messages are gone and modem is requested, connect it to tablet (copter powered all the time)
      4. accept connections questions
      5. it's connected.

      If I plug modem first and let Android open program, it doesn't connect properly.

  • Olá Junior, vc já postou no Brazilian Group Drone

    • Desculpe, mas isso foi uma pergunta?

This reply was deleted.