APM 2.5 hangs on connect to MP

Hi all,

When I try to connect via USB, it hangs on "got param ...".  No errors, just sits there. Orange light blinks slower on the APM.  CLI factory reset works, firmware update works, but can't connect.  

While connecting:

Arduplane 2.76 freezes on got param PTCH2SRV_P

Arduplane 2.67 freezes on got param RLL2SRV_IMAX

Arduplane 2.50 freezes on got param FLAP_1_SPEED

If I just try to boot it, the B and C are solid (GPS lock?).  I don't have a GPS plugged in...

Any ideas?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Eventually also realised that my problem was related to faulty 3.3 v regulator.  Replaced it carefully after watching the excellent tutorial by SparkysWidgets at https://www.youtube.com/watch?v=z7Tu8NXu5UA.

    APM was working fine after replacement, BUT lasted only a few startups. Now back to same problem.  0.9 v output. Do you guys have any better luck?  Do your fixes last longer?



    I had two boards with same thing. It was the hardware after all. The 3.3v requlator was blown up for some reason i measured output of 1v spuld be 3.3v. I replaced the orginal TPS79133 to AMS1117 and works now! I attached a picture where somebody else has changed the requlator. Dont have the camera with me at the moment.

    Hope this helps people out...


    • Nice find.  I checked my regulator and it was indeed blown.  I replaced it and it's now providing 3.3V as it's supposed to.  However, there is still only the green power LED and nothing else.  The computer still does not recognize that the APM is plugged in, which I'm guessing means the USB controller is not getting power?  Or is dead?  Could you recommend the any other suspect components that I could check downstream of the regulator?  

  • Little bit results on the debugging....

    I installed the his simulation software and everything is working fine. I can connect to mavlink. On terminal gyros etc are working. I can write and read waypoints.

    Soon as i install the normal plane software v2.76 mavlink, WPs and gyros are not working. Thre must be something with the software...

    On the his simulation software i hit the load iris default button and got the parameters i found that these parameter were changin when istalling the n2.76 plane software. 

    RC1_DZ default 30 was 0

    RC2_DZ default 30 was 0

    RC3_DZ default 30 was 0

    RC4_DZ default 30 was 0

    SYS_NUM_RESETS defaul 7 was 4

    HIL_SERVOS default 0 you cannot see in normal plane software...

    I changed those values on terminal for the normal plane apm software but still not working. Hope this helps somebody to figure out the problem...

  • Same problem came to me today when i formated my computer and installed new software. I also tryed to install the hil simulator to apm and it connects just fine. Could the problem be that i installed the simulation software?

    When i go to the terminal the ins test tells me that the MPU6000 fails to boot.  I dont think it is broken since i have only connected the apm to usb since the problem started. 

    Is there a way to reset all parameters / write them again to amp the control + f thing is not telling what it is doing so i cannot be sure it has writen the parameters....

    How many people are having this issue?

  • Very same problem here on APM 2.5.  Tried factory reset, previous versions of MP, ArduPlane, ArduCopter, ArduRover.  All hang at some stage of the connect stream.  Do succeed once in 20 or 30 attempts to connect.  Then mostly without initialize or dropping the Mavlink data flow within seconds.

    I suspect a USB driver problem.  Experience same problems on XP and Windows 7 machines.  Tried MP re-install and driver updates, but without any luck.

    Seriously hope someone is looking into this issue!

  • There is no confirmation, but in the console window you can see that there are some files getting updated. Internet connection is required for the procedere. Did you test it?

  • I had this issue upgrading from AP 2.74 to 2.76:

    In the MP type Ctrl + F and click on Param gen.

    The parameter list is updated, and all is fine.

  • I had this problem previously and it was due to different baud rates set in the driver versus MP. It happened after reinstalling the driver, which had dropped back to a different default. Not certain it's the same problem for you, but worth checking (as I had kept assuming it was a problem with the AP or Mission Planner, rather than my PC).

  • Which version of MP?
This reply was deleted.