Arduplane 2.7 RTL and AUTO has zero throttle

I have 2.7 on a 2.5 APM - the problem is that when I select RTL or AUTO the throttle cuts out.

I have read previous posts on this however on reviewing the logs the altitude is correct, the airspeed is working and is correct.  Stabilise works and a have done several flights with manual and stabilise working OK.

RTL does work as when I selected it the Finwing Penguin glided back to home fine.  I did set the AUTO altitude to 75M and it was at 120M when I selected RTL.  However all ground tests have the throttle cut out.

I have auto pilot throttle percent at 50% and have written and read back the correct value.

I am sure the is something simple I am missing.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Folks,

    I am also facing the same problem as stephen, but as u guys said, the throttle wont work on the ground so i will take the bird airborne and check. Another thing is where should i change my RTL altitude, my default altitude in the way point page is 100 so would this be my RTL altitude. And is there any way i can control the throttle percentage during RTL mode. I am failry new to this, pls help.


  • There was no problem just a noob thing.

    Today the Penguin flew in strong winds straight to the waypoints.  RTL worked - just had to let the motor come back on

  • hi stephen, just chk the home alt. the home alt is taken as the default alt when writing way points. if home alt is significantly lower than the last waypoint alt the throttle will cut on switching to RTL.

  • I may not have a problem at all.  I have now thought about it some more and the critical test that I did not do is enable AUTO in the air.

    When I selected RTL when flying the throttle may have just gone to the minimum I set (0) while the aircraft descended to the altitude I set.  Had I left it gliding a bit longer the motor may have started up again at 75m.

    What I did not do, as I was a bit spooked by the RTL thing, was fly it again and select AUTO with my uploaded waypoints.  I have only tested it on the ground which I now realise may not be a good idea.

    I will not change anything and test it in the air on the weekend to see if I actually have a problem.

  • hello,

    I had the same problem and found the answer, have you noticed in the mission planner where you do your flight plan there was a option to hold default altitude this has now changed to RTL default altitude as mine was set to zero down it came on RTL have a look




  • 100KM
    Check your RTL altitude (not Auto). How did you do the ground test? My throttle does not work on the ground.
This reply was deleted.