Hello everyone ! 

After I see RTL mode is working quite well from my last flight, I decided to try automode with some


I flew my plane twice with two batteries . My first flight, started by FBWA to take off, change to RTL to check it one more time, change it to manual to trim the airplane. 

After I felt the trim is done okay, I decided to run the Auto mode to see whether it follows the waypoints.

Indeed, it followed the way points and I think I tried that three times to confirm it works well.

However, the problem begins here on my 2nd flight. 

First, using my trimmed transmitter I ran a Radio Calibration to calibrate radio. Second, I created more waypoints using draw polygon and grid option( mapping is my mission), setting speed as 11m/s . Third, for the autotune, I change the THR_MAX for 100 and AUTOTUNE_LEVEL to 5

I flew the airplane in FBWA mode again, change to Autotune mode to do roll and pitch autotune, then I change to AUTO mode and it was not following the waypoints at all and just wondering here and there.

on the screen I see some error message pops up 

error compass variance
error Velocity variance
error Terrain alt variance
error Bad compass health

Can anyone help me solving the problem ? I am doing my best to find the solution on the web but it would be really helpful to listen to your opinions. 

Thank you !

I am attaching tlog files first one with the successful waypoints flying, 2nd one is the opposite 

first success.tlog

second fail.tlog

7월 28일 화요일 비행 문제 켑쳐.JPG

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    I've had a quick look at your second fail log but can't find the problem.  ArduPilot looks like its trying to do the right thing.  As you can see in the graph below the wp_dist decreases as the plane flies towards the waypoint and then spikes up as the plane heads to the next waypoint so it looks fine.  alt_error is fine meaning the plane is doing the right thing.  And your RC inputs are all flat meaning your not doing any stick mixing override confusing the autopilot.

    You have turned off the EKF and Arming.  You should really have those enabled.  Arming is not only a safety option but will also prevent you from arming if one of your components (airspeed, compass, gps etc) is not happy (which are the errors your seeing on your HUD) thus you can't fly if a component isn't working properly.

    Thanks, Grant.


This reply was deleted.