Beginner with autotune problems


I finished my new airframe which is much better suited to the extra hardware required for a UAV than my previous attempt. I was successful launching, flying and landing in manual mode. My goal was to autotune, however I must still have something wrong. When I select autotune, the plane goes nose up, then nose down and refuses to allow me to pull out of the dive until I switch back to manual mode. I have attached the logs and I would greatly appreciate it if someone could help me out.

2014-05-22 19-21-54_34.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • 100KM

    Herewith mine:


    I haven't tried FBWA, but RTL works, sort of, although it can't maintain altitude. My Skywalker was flying like a dream this last year while on 2.x. This was the first flight I tried using version 3.x Maybe there's a new parameter that should be populated?

    Does it matter auto tuning in wind? I can imagine a gust might cause a false reading on roll or pitch.

    • That is close to the values I use. have you set LIM_PITCH_MAX and MIN correct? mine are 3600 and -3600.
      did you verify elevator throw on the ground, in FBWA?
      I suggest you try to fly it in FBWA. That the plane can't maintain altitude is a bad sign tho...

      I autotuned in winds of 4 bft.

    • 100KM

      My settings are:


      I've now loaded 3.0.3 and will try again. Weird thing is my log file indicate wild mode numbers that are not allocated. I'm not sure if the log is corrupt or if there really is something crazy going on in the APM's memory.

      I'm going to fly next time with a tlog. Next 7-8 days looks like stormy weather though.

    • I have issues with logs when downoaded over MAVlink. did you download your log over MAVlink? try downloading them in CLI instead

    • 100KM

      No, used USB.

  • Hello,

    I just confirmed the elevator, and all control surfaces, are correct in both manual and FBWA mode.

    I really appreciate your help!

  • 100KM

    I was about to post the same thing!! I have the same problem. When in auto tune, I really have to hang on the elevator for 10 seconds + to get it to rise at all. It's also "resisting" down elevator.

    I think maybe the max inclination is too low, I was going to check that.

    Paul - yes, I've been using 2.72 on this airframe for many months flying many auto missions. I've just upgraded firmware. Chris I hope we find an answer!

    • I've just done a couple of autotune sessions and I haven't had any problems at all.
      What are your initial PID settings and autotune level? it just might be too soft for proper responses.

    • My autotune level was set to 7.


    • well... your PID's seem very low. Do you have good control in FBWA?

This reply was deleted.