Lose all servos on takeoff - Pixhawk


I've been using a Pixhawk for a while and I've never had this happen:

We calibrated the accel/compass and gyro when we arrived at the field

All sensors looked good after calibration.

On the ground all of the servos worked (tested throttle as well)

We performed 6 throttle run-ups, and sustained for 2x10sec runs. All surfaces works and the system was armed before takeoff. 

We launched the plane from our catapult (~2.5G's) and right after launch we lost all servo control. After the crash, we somehow regained servo control (we tested right after crashing without arming).

On approaching the plane, there were blue/red lights flashing, however the logs don't show a reboot. 

We've had this happen twice on the aircraft - once before upgrading to 3.5 and once after. 

In addition, after looking at the logs, it says that the plane pretty much started spinning right after launch (IMU went total haywire - just straight up spinning) however, would this cause an autopilot reset? 

I can upload the log files if people want, but they're pretty long (we go through a ton of tests before takeoff, so the logs are since then). 

I'm stumped - anyone have any ideas? 

Edit: I've added the logs and google earth KMZ if people want to see them: 


Edit: We've flown this plane multiple times before, with this autopilot (and the same setup, transmitter...etc). 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok - so we'll switch to the external power module then. However, some things are stil left unexplained that I'm concerned about. 

    a) Why didn't we need to re-arm if the Pixhawk restarted?

    b) If we have dips in power, do you think that would be enough to effect our PPM receiver? We've never had issues like this before our last two flights (we've had 5+ flights with this setup). 

  • That is the servo rail voltage? We measured it with all the servos pulling max Amp and it was steady at 5.5V (with the same battery, once we got back to our lab). 

    Edit: In addition, if it was a power reset, then why was the plane still armed afterwards? Usually the Pixhawk requires a re-arm for the servos to work after a power cycle. 

  • Another question - do you think adding a zener diode of the servo voltage lines ould help us at all? It says to do so in the manual. 

    • If you are not using a Power Module, you should use a zener diode as per the instructions on the ArduPilot Wiki.

    • For what its worth I would add the Zener and the cap as seen in Wiki. I have seen pixhawk shut down and reboot using digital servos. Remember to power the rail with good clean reliable power because the power that is plunged into the rail is powering your servos. The power module only powers Pixhawk and will not power servos.


  • Hmmm - I took another look at the log files (specifically the throttle output, RCIN C3). We do a ton of throttle run-ups, but it doesn't look like there was a throttle run-up right at the at the end of the log. The throttle was at 100% at takeoff - so I'm not quite sure why this is happening. I also have the log right after this one, and that one has throttle hovering around 1000 (the throttle min of our system)

    You make a good point about the servo voltage transients - however we've never had an issue in the past - we will change to the power module. 

    It also didn't look like the plane restarted, since we didn't have to re-arm it after the crash to move the servos again. 

    May I ask why you think the launch occurred at the end? I'm just trying to learn what to look for :)

    Note: I've added the next log file to the link above. 

    Note2: After the crash we waited for a bit (taking pictures of the crash and such) and then tried to move the elevator and rudder (which were still connected). It seems as though the movement of the elevator and rudder are in the second logs. 

    Note3: I've also uploaded out parameter file

  • @Samuel,

    do you really love your catapult ?

    2.5G is all about weight increase from  

    m x G


    2.5 x m x G

    If 2.5G is calculated for a heading vector, so it doesn't mean, PCB board platine was not under < 10G shock at some spots at some moment, the same for individual electronic parts,

    mounted vertically, horizontally, some loose, the same for cabling, wires and lipo battery shock.

    Try to calculate drone's speed on living the catapult from  acceleration equation and check with manufacturer if servos  elements can be subjected to such stress ( wire coils) without side-effects.

  • have you checked the current of the system at full throttle for several minutes.

    I had this once, the system consumption was very close to what the battery can handle, since that the pixhawk was rebooting during take off.

    • We have two batteries - one that runs the motor (throttle) and another that runs the servos/pixhawk/payloads to ensure that this can't happen.

      Also - the pixhawk didn't reboot during takeoff, it just wasn't sending and RC signal (it actually looks like all of the RCIn's were not reading correctly). I can verify this by looking at the logs - the logs show the takeoff, crash, and us carrying the fuselage back.  

    • Did you range test your Tx? Might be getting interference when you power the motor up. Ask me how I know that one...
      Also, be sure if you do a range test that you turn the TX power back up to high, Ask me how I know that one too...
      What mode were you in on launch?
This reply was deleted.