Motor not responding to inputs on Ch 3

Whenever my ESC is connect to Ch 3, I have no control, but if I move the ESC to any other Ch (1,2,4) it responds as expected.

I am using a Taranis Plus and X8R to Pixhawk via SBUS. Below are pictures of my RC_MAP and Taranis input and mixes. I tried creating a new model in the taranis and redoing the binding. After this I redid the radio calibration in Mission Planner.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    Chris you should probably start a new discussion with your issues rather then hijack an existing one :-)

    Create a new discussion in the relevant vehicle section (I assume your talking plane) and post a log file there (dataflash preferably) and we will have a look.

    Double check that ARMING_REQUIRE is 1, BRD_SAFETYENABLE is 1 and ARMING_CHECK is 1.

    Thanks, Grant.

  • Developer

    Its recommended you leave arming enabled and read up on how it works on the wiki.  It may identify problems before taking off that you can resolve without resulting in the loss of your plane.

    Thanks, Grant.

  • Set ARMING_REQUIRE = 0 and you will see. If it does not help, your problem is most probably not caused by arming.

  • Yes, the radio calibration screen should show the inputs from the various channels as seen by the APM.

    BRD_SAFETYENABLE is not the only arming parameter.  That is only disabling the input from the onboard aircraft safety switch.

    Read through the following page for additional parameters you need to change in order to auto arm:

  • Check the channel inputs on mission planner to confirm if the throttle signal is making its way through.  Mission planner will also tell you if you're armed or not, as Petr suggested.

  • Arming?

  • Have you tried plugging a servo in to channel 3 and seeing if it will move?  I have a dead pin on my board on channel 6, so I just have to use a different channel.

This reply was deleted.