Hello everyone,

I'm trying to setup the loss of RC comms with my RMILEC long range system (LRS). Basically, there are 2 modes you can choose from (custom servos and channel positions or hold last servos positions). The system works by sending regular RC commands to a FRsky X8R which is connected to a long range base station which forwards the RC signal to a long range rc receiver on the aircraft.

I have configured ArduPlane to have 5 flight modes on CH7 (manual, fbwb,fbwa,cruise and rtl). I have also configured the RC receiver failsafe (frsky x8r). Basically, for the failsafe, I'm putting my CH7 switch to RTL mode.

If I turn my Taranis off, Mission Planner tells me that my plane is going into RTL mode, YEAH ! However, if I turn the LRS off, I can see in Mission Planner that my CH7 pwm value changes to the RTL mode but the Current Flight Mode doesn't change. Is there any way to make this work ?

Thanks, René

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thanks Lherning. The Throttle Failsafe solution is the one I'm using for now.

  • Good one,

    I would enable Throttle FS to the PWM value Pixhawk get from the repeater when your LRS is turned off. Or would find a FS solution on the repeater itself.

This reply was deleted.