RTL mode, Loiter mode no Throttle

 Hello everyone ! 

I am new to pixhawk and ardupilot and currently have some problems with my first flight.

  I tested my first built Skywalker 1880mm T tail shape frame and for some reasons, I was not able to get any throttle for the RTL mode Auto mode ( I didn't plan any way points ) nor Loiter mode. 

I already checked some of the similar threads about No throttle in RTL mode and nose dive problem but I am still not quite sure about what would be the issue.

I changed my parameters today by loading the Aero M parameter since it is similar frame . ( I didn't load them fully and I the attachments shows what had been changed. ) Hoping that  it will solve the throttle issue.

Here are some of the things that I am not unsure of at this moment .

1. when setting home altitude, the default shows 100m what is this mean ? what happens when setting home altitude to zero ? 

2. Anyway to check the autopilot is properly working on the ground ? I do not want to lose my first built plane

3. what is default altitude on the mission planner flight plane tap on the bottom of the screen ? mine show it is 100m and I do not know what that means 

Thank you guys in advance for the help :) 




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Mission Planner's "Default Altitude" is just the altitude that will automatically be used when you create a new WP, before you make any altitude modifications. It just saves time so you don't have to enter an altitude for each created waypoint. It has nothing to do with RTL.
    The parameter you are thinking about is ALT_HOLD_RTL. Try setting it to -1 for your test, this will cause the plane to RTL at whichever altitude it happens to be at when RTL engages. Then you can see if this parameter is causing the throttle reduction. A common mistake is not realizing that this parameter is in cm, not meters! If you want to RTL at 100m, you need to enter 10,000. I see you didn't make this mistake in the screenshots, but it might help someone else reading this.

    What are you referring to when you say "Home Altitude". Do you mean Mission Planners HOME LOCATION Alt? That should automatically reset when you connect at the field.
    • Thank you iskess for the help. 

      Today I flew it and it indeed works well for RTL and Loiter mode ( now I have throttle )  

      1. However, the throttle that RTL mode uses eats up 10A and I definitely I would like to lower the throttle value. I would like to know how I can change RTL throttle or auto mode loiter mode etc

      2. I also tried Auto mode but it seems like the plane is not following the waypoints. The trim of the plane was pretty bad and that is the only reason I can think of right now or may be the rudder direction is opposite ( I will check the rudder  tomorrow.) I would like to know what could be the reason for airplane not following the waypoints.

      3. During Auto mode I saw error terrain alt variance and auto mode act similar to RTL mode, would this be the possible reason ?  

      I am attaching Tlog files and would like to get some help as soon as possible :) in the mean time I am going to do my best to find the answers of my questions by looking through DIY Drone 

      Thank you ! 


      2015-07-26 18-05-20.tlog

      2015-07-26 18-58-28.tlog

      2015-07-26 18-05-20.tlog.kmz

    • It sounds like you need to read the tuning guide in the wiki. http://plane.ardupilot.com/wiki/flying/tuning/

      The terrain error shouldn't effect auto wp tracking.

  • My guess is that you were higher than 100m when you engaged the loiter and RTL modes.  The first thing the autopilot will do is go to the default altitude which is 100m usually.  If you are above 100m then it will cut the throttle to dive to 100m before restarting the motor to maintain altitude.

    Happened to me when I first started with APM.  I thought exactly the same thing.

    If you set default altitude to zero then the plane will fly to the waypoint and try to go to altitude zero relative to home which is the ground.  The default altitude is the height above home that the aircraft will fly if you set waypoints without specifying the altitude.  It is also the altitude that loiter and RTL will go to to circle home.

    Home is really important and you need to check you have a valid home setting before you go to any of the auto modes.

    • Stephen Thank you for the reply and explanation . But I have some more questions 

      I was flying around 50m and I believe that I didn't change the default altitude so it should be set as 100m 

      For the home altitude , the value is 100m for mission planner autofillup  and I think I changed that to 0m ( I am not quite sure about the meaning of the home altitude)  but if you are saying default altitude is height above home altitude it should climb up for the RTL and Loiter mode right ?

      I am confused please help me out :) 



This reply was deleted.