Discussion group for ArduPlane users

1475 Members
Join Us!

You need to be a member of diydrones to add comments!

Join diydrones

Comments

  • just want to be sure.im a beginner so i really2 need guide in this thing. hope you dont mind helping me.thanks alot k. 

  • Admin

    @Aku,

    Yes, you can do that, but the USB connection is not designed to power anything on the APM servo output power rail such as a servo. Why do you want to run the APM on the USB connection with J1 installed?

    Regards,

    TCIII ArduRover2 Developer

  • hye!@ Thomas J Coyle III is it ok if i connect the usb cable to the ardupilot board with jumper jp1 connected and without power module cable and gps module?

  • Here is my log file.

    45percentLoiterFail.zip

    Just around 45% of the way through the file, I put it in Loiter.  It circles, but loses altitude.

    What happens before is other stuff, and you can see fails throughout, but this is the one I'm most perplexed by.  After this I was able to recover, but in doing so I lost sight of it a few times behind trees, so it gets kinda rough....

    https://storage.ning.com/topology/rest/1.0/file/get/3692866371?profile=original
  • I have an APM 2.5 and It's working fine in Stablize mode, but when I switch it into LOITER or RTL, it goes for the ground.

    I've reviewed the logs, and the alt_error just jumps up when I go into any of these auto modes.  I have my APM inside my plane, but it's not 100% sealed and I haven't done the cotton puff over the barometer yet as I thought it being in the plane was good enough.

    Am I on the right track for explaining the alt_error and that this is the reason the plane doesn't hold altitude on loiter?

    The ALT_HOLD_LOITER was also set to 10000cm, which was just nuts, but I would have thought my plane would go too high if that were the probelm...

  • Admin

    @Aku,

    Follow these wiki instruction on how to power your AMP2.6: http://plane.ardupilot.com/wiki/common-apm25-and-26-overview/#APM_2...

    Powering the APM with and without J1 is explained further down in the wiki.

    Regards,

    TCIII ArduRover2 Developer

  • hye!can some one guide me how to setting up ardupilot v2.6?i have issue here because should i connect the jumper to the board? because i want to power it using USB cable.

  • hi,new here,so happy

  • Since I haven't been on here for awhile.  What is the new development of the Nitro and the APM.  Last I new vibration wasn't good.  Has there been any new developments as of late?

  • Wait till that happens to cars too ;)
This reply was deleted.
E-mail me when people leave their comments –

Cruise speed

Hi,I want to adjust cruise speed.At default settings I have a ground speed of about 42km/h (without airspeed sensor), and I think the optimal speed should be lower. In the mission planner I have value "Cruise speed", default 12m/s. I updated it to 9.5, but don't see any change in actual cruise speed.How to set cruise speed?Are these different settings with RTL speed? For RTL I prefer keep it as is - less efficient, but more reliable.Is it possible to adjust cruise speed during flight, providing…

Read more…
0 Replies

Long distance LiPo

I'm currently building a Talon (v3), mainly waiting for parts.While looking for high capacity batteries I found out two things; There are a lot of brands, and prices are still steep in the high-cap regions.I've also seen a few people on the Tube using 18650 cells, but none of those explain why.Does anyone here have experience with these custom 18650 packs?And which 'cheap' brands of standard 5~12A 4S seem to work best?I'm going to use an Emax GT3526 710KV swinging a 13x6.5 prop, which should…

Read more…
5 Replies

Quad plane pitch problem

Hi I have been setting up 2 quad planes, pretty standard setups...flying wing with 4 vtol motors and a rear mounted pusher motor. Both builds wich are on different firmware versions have reversed pitch in quad mode but correct pitch and pitch stabilisation in plane mode. I cannot for the life of me find a parameter related solely to quad pitch reversal. Is there anyone out there that can help with this? Thanks.

Read more…
2 Replies

PreArm Check Error : Gyros inconsistent

Hi guys, I have a Pixhawk from Radiolink and always in every first attempt of armed I get the error "PreArm: Gyro Inconsistent".The most strange thing is that i'm using only the external gyro+compass. i disabled the internal to avoid this issue. Also- I tried to recalibrate the gyros at least 5 times.- I changed the firmware version from the latest to the 3.8.53 because i have a friend with the same board and he does not have issues.But i have the same behaviorIf i disconnect the battery and…

Read more…
2 Replies