Setup trouble - motors only runs in shorts burst

Hi all,

TCIII asked me to post this here, so more brains could tell me where I'm being newbee or stupid. Just don't RTM me please, as there is a lot of stuff to cover for a new head here, and alot of doesn't count for a boat or rover. :)

Okey, back in april i started build a boat, which should be used together with my  spare chartplotter/fishfinder (Lowerance Elite 4 HDI) a few photos of that can be found here:

I have goten a bit longer, and the boat have been on a few trips on the water, but there are something wrong with it. 

Today, I tried to  make it run again, sometimes it runs one engine, then the other, only for a few seconds. Seems like an initiation of some sort. Other times it runs one engine for a long time, and the other just now and then.

My parameters: carlparam.txt 

And my log from MP messages: carlmessage.txt


This is brain part, it's mounted like this so I can take it with me.


Overview: The part at the bottom of the pictures is the real middle section and will be as good as waterproof for splashing etc.

The box on the middle section will contains the brain (picture above) and the fishfinder/chartplotter.
The hulls are made to be able to have 2x 12V 12Ah batteries installed each, if ever needed. (this setup seems to close to 20hours run time. (close to 1amp drawn for both engines and combo fishfinder/chartplotter)

electric.jpgElectrix madness part 1


electric madness part two :) 
(this is temporary as the plan is to solder all connections that don't need to be unplugged, but for the testing, it is great to be able to disconnect, and connect without needing to solder :)

If anything else is needed, scream for me (i.e.. reply to this post) or if you have the "newbee, do this" solution, to the same :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Admin


    Here is what I think is going on with the skid steering motor control of your boat.

    From your Full Parameter List:

    Here is how your R/C receiver channels are mapped into the APM control space:


    Here are your R/C input to the APM from your receiver:





    Presently the APM navigation code thinks that your PITCH (throttle) input is on channel 2 and your ROLL (steering) input is on channel 1. However you appear to have the output of the Futaba R/C receiver on channels 1 and 3 which does not match the R/C map for PITCH and ROLL.

    We also need to know what the function (ie aileron, elevator, etc.) of the channel 1 and channel 2 outputs of your receiver are to be able to match them to your R/C MAP.


    TCIII ArduBoat Developer

    • Hi, 

      I have removed all electronics from the boat, and taken it in. But I'm unsure how to troubleshoot futher. 

      I'll try to use input two again. 

      Any tip for how to find the mapping for the receiver would also be greatly appreciated



    • Channel assignment: 

      I use channel 1, 2 5 and 6 on the futuba receiver.

      Channel 1 is connected to apm input #1, channel 2 is connected to apm input #3
      On the output side output 1 is connected to the left motor, and output 3 to the right motor. 

      Without connecting anything to the outputs, I tried to use mission planner to see which bars moved when I tried to move the joysticks

      I have tested the following:

      Right Joystick forward, made the bar on the throttle fall to 1105
      Right Joystick backwards, raised the bar on the throttle to 1920

      Right joystick to the left, Roll bar moved to 1123 and to the right: 1948

      The pitch and yaw bar don't move. 


      I removed all the electronics from the boat. Connected the speed controller directly to the receiver channel 2 and try to go forward and reverse with that. FAIL!

      reverse seems ok. 
      forward is the same issue as when going through the apm. I.e. not running 100%, starts, stops, starts stops...

      I have tried to setup the speed controller again, but still don't work.

      The esc have two lights, red and green, which both are lit when idling. going backwards the red light are lit, going forward, both are blinking randomly, no pattern. mostly they aren't lit. 

      What is strange is that changing the cables on the engine, so that +/- changes and the engines runs  in the different direction it still works in reverse and not forward on the controller. 

      Both ESC works the same way. 

      I also tried with another receiver to check that it wasn't a bad receiver that made the issue. 

      My conclusion: the same interference that made needed the APM being powered from it's own battery make interference with my esc. (or I have two defect esc or a defect transmitter ) 

      I didn't test with the apm since I presume it would be better to get the channel 2 on the futuba receiver and the speed controller to work before I add the apm into the mix. 



    • Admin


      When the right joystick goes forward, the throttle bar should go to 1920 and when it goes backward it should go to 1105. You need to reverse the elevator (pitch) joystick at the transmitter. 

      The right joystick readings going right and left is correct.

      In the Full Parameter List you need to change RCMAP_PITCH to 3 and RCMAP_THROTTLE to 2.


      TCIII ArduBoat Developer

    • Hi, 

      I have reversed the right joystick, forward/backward motion, so the bar are changing like described. 

      However, when I'm trying to change the rcmap of pitch and throttle the left motor runs continuously and only slows down, but don't stop, when I'm moving the roll stick (Sideways movement on the right stick)

    • Developer

      hi Carl,

      Sounds like it's an problem with how the ESC are set up or the hardware.

      Can you first try to get it running properly without the apm,  that would be the best option for now I think.

      Sometimes starting again from zero ist a good way to trouble shoot and get a better view of complex setups.



    • Admin


      You still need to answer my questions at the bottom of my post above your last post if I am going to be able to help you.

      The RCMAP parameters are in the Full Parameter List.

      Before moving anymore connectors, I suggest that you try changing the RCMAP_PITCH to 3.


      TCIII ArduBoat Developer

  • Developer

    Hi Carl,

    just a thing i see with your Setup.

    You should try to separate the telemtry radio little further away from the GPS to be sure there is no interference that can degrade GPS reception.
    Just placing them as far away from each other as the cables and space allows should be sufficient.
    nothing that would prevent it from working but just to mention it.

    Since you are using brushed motors the "switch 2 motor wires" for reversing direction does not work here i guess.
    I assume your testing was in manual mode ? can you try if it works in STEERING mode  ?
    i am not sure how to make sure its not something related to the mixer right now. probably a tuning issue or something hardware related.

    One thing i would try first to narrow down the problem is testing one esc/motor combo at a time with both outputs to see if its related to one side (esc or motor).


    • I'll try steering mode later today, I don't need the learning mode, so I can swap that.

      Brushed motors change the directions if you swap the cables. 

      The two main issues right now seems to be:

      1: the motors goes quite well in reverse, but only small burst forward

      2: to much interference from the motors, which makes the apm going "wild". quick dirty fix: add another battery just for the apm and fishfinder/chartplotter combo.

      for the gps/telemetry issue, that isn't any trouble as i broke the cable earlier today, so the rest of this vacations I have to manage without telemetry :(

      (which cable from 3D is that anyway?)



    • Admin

      Hi Carl,

      Can you capture a tlog and later download a data flash log of your boat going forward and backwards to better understand why you are having a forward throttle issue.

      Also, will you please verify that you have the Futaba receiver aileron output connected to the APM receiver input channel 1 and the elevator output connected to the APM receiver input channel 2.

      If that is the case, then try connecting the left motor to the APM servo output 1 and the right motor to the APM servo output channel 2.


      TCIII ArduBoat Developer

This reply was deleted.