ESC cut off with 3S, but keep running with 4S

i have a very strange problem today..

everythign was runinng fine with a 3S. then i tried a 4S and ok.

put back the 3S.

now some motors cut off at half throttle just before taking off from the ground.

i can hear a beep like ESC resetting? i dont understand what it coudl be.

i heard could be bad wiring? but why it works with 4S and not 3s then?


another rookie mistake: i was using both 4s and 3s batteris without noticing the Batter Module was setup for the 4s. bottom line APM was cutting off power because they thought the battery was very low, 12v instead of 16v fo the 4S.

again, the battery failsafe was the problem. it;s the second time the batery failsafe causes me problems. i just disabled it and done.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Glad you sorted it. 

    I have no idea why the software doesn't just auto-detect cell count and let you define a per cell voltage alarm threshold instead.. would make it easier to use and avoid these kinds of problems when you forget to go in and update the threshold.

  • Try recalibrating the esc's
    • i changed all the ESCs with older 30A esc.... still same problem... i think is the APM at thi spoint...

    • tried already.... but motors 1 & 2 (on a Y6B config) are keeping cuting off at half throttle...

      i'm giving up.... it's just a mess this hobby

  • up

This reply was deleted.