No heartbeat packets received

Just received my Y6 today but I'm having trouble getting the Mavlink to connect. It connected this morning on my Windows 7 machine but this afternoon when I tried to connect again it times out.

APM 2.6 Mission Planner 1.2.69 Mav 1.0

When I plug the usb from the Y6 into the pc Windows seems to recognize it. Arduino Mega 2560 shows up ok in Device Manager.

After timing out a black window shows up (looks like a DOS window) that apparently is a log for the connection attempt. I can't copy the text in the log. None of the logs in the "Terminal" menu are turned on.

I tried to install Mission Planner on my Win 8 laptop but although it let me install the driver once, it too won't connect and the things I've tried (uninstall MP, download driver directly, etc) haven't worked and the Aruduino driver isn't properly installed.

Any help would be appreciated. I'm new to this hobby and am probably missing something that is obvious. If I need to post logs or other information it would be useful if you could tell me where to start. 

Thanks for your help.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Wessie im having this same problem man, how can i be sure that is this 3.3V chip issue? i want to be sure before contacting 3dR

  • Hey guys!
    I don't own an Y6, but I got my first APM (2.6) two days ago and I still can't connect.
    Same problem as described from Gsouth: after clicking "CONNECT" comes a window "Trying to connect. Timeout in 30", after 30 seconds comes second window "Can not establish connection\n. Please check..." and after clicking OK is the error message "Error - No Heatbeat Packets Received"

    What I've tried:

    - trying it on two PCs - Win7(64bit) and Win 7(32bit) (all the usb ports)

    - using 3 different cables

    - turning off bluetooth, other usbs

    - reinstaling MP, restarting PCs

    On both PC's the APM is recognised as a com port and I used the right MP version, Com port and Baud rate.

    I ordered my APM from the 3DR official dealer in Greece and I REALLY want to try anything else but returning it, because I left Greece already.

    Can you give me some other tips or links to other groups/topics/forums, which can be helpful?

    Thank you in advance!


  • So Many questions...

    1. Y6 RTF or KIT?

    2. Have you installed the Y6 firmware yet?

    3. have you selected the correct com port and baud rate in MP?

    lets start there for now, then we can go from there.


This reply was deleted.