Second Test Flight Second Crash, Need Help!

Hello folks,

I managed to get out into the field for the second test run with my y6 tonight, and once again it crashed.

This first crash I do believe was my own doing as the grass was to tall for lift off and also a prop not came off loosing a prop, although only fell from 1 metre approx, there seemed to be no damage.

Tonight I had a different issue, which may be a result of my first crash.

After my crash tonight (using a pre build wooden lift off platform) I had a similar crash where the front end seems to drop resulting in a instant roll not even half a metre off the ground.

I noticed something that caught my attention, the lower right prop did not seem to be spinning from sight with the same rotation force as the others. Perhaps a trick of the eye but uncertain.

Would this be a sign of a burnt out motor? How could i check to be certain?

(I never did any ESC programming as i could not manage to get pixhawk to boot in all at once esc program mode.)

Could this be the issue?

Throttle doesn't seem to have any effect until mid point, does this seem correct?

Finally there are no local dealers who sell APC 11/4.7 props (one shattered in second crash need a sf and only have a spf), would there be any efficient size replacements?

Would completely changing all 6 props to 10/4.5's work?

Motors & ESC's

-jDrones 850kv motor's + jDrones 20A ESC's

Thanks in Advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have (unfortunately) a fair amount of experience with motor-out crashes with the Y6.  Could you upload your logfile?  I would be happy to have a look.

    • I'd be happy to do so, just not sure what the log file is or where to retrieve it from? Be glad to upload though! I managed to get the motor running perfect again and did discover what my issue was. 

      I had both top and bottom motors spinning in the same direction, which must of occurred several months back when i initially built the Y6 and had shortened all the motor wiring requiring me to re-solder everything which is where i'm assuming i made the error. 

      I also finally calibrated all the esc 's so I'm thinking that will make a big difference also. 

      The motor failed temporarily think as a result of the crash, (well more of less was trying to drive itself into the ground while rolling forward).



    • There are plenty of instructions out there, just google it.  It's not hard, but there are better descriptions that I could give you here.  But if you already figured it out then maybe the problem is solved without logs.

    • Craig,

        Today my Y6 had its successful maiden autonomous flight. I took the exact opposite route you did by trying to understand the inner workings of the craft and programming the radio so that it could interact with Mission Planner. I don't see any other way before trying autonomous flight.

      My Taranis radio is out for repair so I had to start over with the 9XR. Updating the firmware on the radio and FC, not to mention having the latest Mission Planner is important.

      If you think your motor situation is correct, I would suggest starting from page one and make sure you follow all the setup instructions. If your plan is to not use the radio at all for flying, it is still necessary to do the motor/ESC calibrations et al.  I had plenty of minor crashes before getting the feel for flying this machine. Today I felt confident enough to try Mission Planner, but had the radio in my hand in case something went wrong like compass glitch or who knows what. At least with Failsafe enabled and working it should come home.

      This video from Randy McKay helped me to slow down and make sure I knew the basics of using the radio and flying manually before planning missions.

    • Great news!!!, how'd it go?

      Well I have been building this Y6 for 4 months (since january) without even considering flight and did take a lot of time programming everything as well as on the detail of the setup (built many detailed picture diagrams incase any of my colleagues up at the university decided to try a build flawlessly). 

      The issue i think i had was when I had redone all the wiring within the Y6 in order to clean up, minimize and streamline what is on the Y6 I must have reconnected all the bottom esc 's to the motors in the exact same way as my top motors (problems solved now while calibrating all my esc 's). And also trying to throttle up as slowly as possible (little first time nerves), seems to be another thing I realized was not the proper way to lift off.

      I've switched all the prop adapters also to simple nyloc nuts so I won't have any lost prop issues anymore.

      As for mission planner, i'm a apm planner user as i haven't found mission planner for osx and personally hate windows with every inch of my existence as it has been nothing but a nightmare for me, but thats a whole other topic all together. 

      And apm planner can be very sensitive often requiring a fresh restart with the telemetry plug in upon start up in order to be able to connect with the Y6 and maintain the connection.

      The turnigy 9xr, I only merely bought it for safety reasons, with no intention of doing any firmware upgrades ect.. as I have little knowledge in how to do so and that it seemed to work well the the XJT module,  my concern is merely to learn to be able to control it enough to do basic functions as most of its uses will be done far away from any urban environment, often well into forested areas using the autonomous functions. But I have went through every every page of any instructions i could find (I sometimes get in a hurry as a result of having such little spare time which is why i probably tried to opt out of esc 's calibration after the all at once wouldn't work).

      I am by no means a hobbyist, with my true intentions being research, (with maybe the opportunity to get good outdoor shots as well as some minimal scouting uses,) as probably 14 hours a day of my time is dedicated to such research in a lab or out in the environment (i'm an environmental biologist). 

      This video is very informative!!!

      Thanks DG,

      Craig P.

    • APM/Mission Planner for OSx

  • Update: 

    Upon checking all my motors when manually programming my esc 's I ran to a couple of problems,

    First being all my motors were in correct location, but unfortunately without realizing two of them (bottom tail was spinning ccw same as top) and (bottom left was spinning cw same as top). I will now go ahead to correct this issue

    @DG: Good thinking on that one!!!

    Secondly the motor I thought may have been fried, when attempting to calibrate i get no response from esc (beeps), but when i try to trigger the throttle it does make a rather bad sound like its electronically stuck and the motor spins slowly and it a distorted fashion back and forth?

    So my question now is, would this be the motor thats fried or the esc itself? or could it just be a mere wiring issue.

    @Andy: manual calibration works great thanks again for the advice!!!.

    • I can tell you I had some pretty bizarre motor behavior before I synced them all at once on the copter, so I wouldn't be surprised if the clicking were part of it. I have not had to replace a motor or ESC, yet.
    • I've managed to get all the esc 's to manually programming individually but wasn't able to do an all at once sync with the pixhawk? Is there a special method in doing so?

      And ya i'm definitely going to check my wiring anyways since i had to reset the proper rotation on two motors (both successfully changed now, so i'll see then is thats the case.

      Glad i did find what may have caused the crash though which was incorrect rotation on most of the lower motors.

      Thanks again!

    • So I tried the motor i thought was fried with a speed controller that was on a rear motor the motor worked great!

      So i attempted to reconnect the same esc + motor combo that gave me issues and worked flawlessly again?

      Strange that it did that cause i didn't change the wiring scheme within that combo just kept it the same and it spun no problem. Maybe it was just being stubborn i guess...

      To correct the wrong rotation i merely switched the red wire from A (esc wire) to the C (esc wire) and vice versa for the other one.

      I think i'm going to order some spare parts anyway for times when i need to run tests and stuff, would just me practical.

      Now to wait for new props to arrive next week...

This reply was deleted.