I fly AUTO very, very often, but this time something weird happened.

When I made my mission it looked great

Mission Planner On Windows 8


But when I selected Auto this happened (Pink AUTO, Red RTL)   The RTL worked fine


When I loaded my mission up on Droid Planner you can see it tries to take me into the Atlantic ocean



Here is the log file 2015-03-31%2013-05-03.log

Here is the flightplan LEGODroneAutoflight.txt

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    yep its a bug, and its been there for a very long time

    fix is here


    • Michael, the latest update works line now shows actual path that the drone will fly to 0,0, ty

      One question, I think it would make more since to default the "Add Below" to Return To Launch 0,0 rather than Waypoint 0,0 since RTL would never cause a fly away by default and can actually be defaulted to 0,0 without drawing the long line to 0,0

    • ty, you guys are the best devs!

  • Developer
    That's a bug for sure. Report here https://github.com/diydrones/MissionPlanner/issues
    • Welllll, you could call it a bug, but using the "Add Below" feature very clearly and obviously shows "0" in the Lat/Long fields, and nonsensical data in the others, so, how much spoon feeding do you really want ?


    • If its going to make my quad fly 1,200 miles it should display a line on the map exactly like Droidplanner does.  The button could have accidentally been hit by a user or someone simply selected the wrong command.  This would certinatly cause an attempted fly away.  There is no doubt, the line should be there if its going to fly there, or until they change it to say Takeoff.

  • I had the same problem once, for me I hadn't properly loaded the new flight plan so the UAV flew to the previous coordinates(which were several miles away). The RTL feature works because it sets "home" when it arms and not from the flight plan. 

    I had to go into the saved flight plan using the "load" button and delete that mission before the UAV would listen to the new flight plan.

    • ty, but I can make a brand new flight plan, add a couple waypoints by clicking on the map, then click the "Add Below" button (default is 0,0).  Problem happens when I added a couple more waypoints while leaving the 'Add Below' waypoint and the 0,0 waypoint never visually shows on MP (PC) so when I flew it tried to go to the Atlantic, thank God it was first waypoint.  Although Droidplanner plainly shows it going into the atlantic the PC version does not making the 2 apps inconsistent.

    • I don't know, sounds like a scripting thing. Common response would be to remove and reload the program, which give you a clean slate. Anti-uav methods are being experimented with so I wouldn't discount spoofing either if it's a repeating offence. 

    • Just go to MP for Windows, add a few waypoints by clicking on map, add one by "Add Below" then a couple more by clicking on map, you will see that the one by "Add Below" is at 0,0 which is Atlantic Ocean but it never shows on screen :(

      No need to fly or load in flight controller

This reply was deleted.