Autotune "ERR: Autotune-2" Bad gains

Hi everyone.

I have 2 copters, a small hex and a big quad. Both are running 3.2.1.

The small hex starts autotune instantly, despite having pretty bad vibrations, no issues there, and this tells me I am a) doing it right and b) my transmitter is set up correctly.

On the big copter, as soon as I try to run autotune, it does.. nothing. Entry in the Logs is "Err: Autotune-2" every time I try to activate it. Yesterday, I actually got it to work by resetting PIDs to default. Today, I switched to 12" propellers and tried to run autotune.. again, Autotune-2, not even trying to run autotune.

No other errors that could cause this. Also, at this time, it's hovering perfectly fine in place, no twitching or anything that could be at fault. I also tried to send the flight mode change over Tower for Android, with the same effect.

Any ideas? I'm tearing my hair out over this.

I attached my log. The GCS errors are due to the fact that I had my cellphone with the radio in my jacket, merely using it for announcements.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • MR60


    I do not know much about Autotune but there are some things to verify for it to produce good results:

    -Vibrations Under control, i.e. your Zacc should not oscillate more than +2 and -2 in loiter (around value of gravity -10)

    -Your frame must be mechanically rigid. If it flexes, if things are loose, autotune will not make it right.

    I have read mutliple times that autotunes does not work very well on large props/low Kv. I do not know if this is still the case with 3.2.1.

    It would be good if Leonard (dev who programmed autotune) could chime here.

    • Vibrations are low, props are balanced.

      The frame is rigid, it's a GFK frame with aluminium arms.

      Motors are 900kv MS2216 on 11-12" props.. I don't think that qualifies as large prop/low kv.

      It appears I have to set P/I to 0.1 or lower for autotune to start at all.. once I reduced the values greatly, it started autotuning again.

    • Finally Sascha, did you fond anyexplanation for this behavior?

      I am having the same problem and try to found what's go wrong.

      Please feel free if you have found any solution

      THanks for your help

  • Well.. second time around, I dropped P even further (1.0) before trying.. and Autotune instantly started, no complaints.

    I really don't get it.

    I also seem to have found a bug, I will report this one seperately.

    Also, how long does the APM generally take to write the logs? I have a bunch of truncated logs, despite landing without issue.


    • Annnd.. it happens again. Tried to run Autotune once more, since the roll value it came up with was way too high (1.825, copter was waving arms like crazy when flying forward).. Error: Bad Gains.

This reply was deleted.