I had initially raised this question in Arducopter 2.x group yesterday but since no one replied and I really need help, I am posting this question in the Arducopter User Group.

Here is the situation:

I am doing a project to augment Search and Rescue operations as we know it with Semi-Autonomous UAVs. About a month ago we tried to join modules together but we hit a major problem with making the Arducopter fly in AUTO mode. We need to get the Quadcopter following the waypoints before Friday, the project presentation date. 

Below is a screenshot of a log we downloaded yesterday. I have also attached the log to this post with our params file. The waypoint file for this flight only contained two waypoints and an RTL mode. Before this flight we tested Loiter mode and it worked well. In this flight however, we had multiple fly-aways with the Auto mode. 


We believe that our project has potential. We have presented at the NCUR conference last week and won an award yesterday for our project, but for this project to come together we need a video of the waypoint navigation working with system by Friday. 


Thank you Tsoi and Boland. 

Yesterday (4/21) I did three things before flying:

1. Downgraded the FW to 3.1.5

2. Twisted the GPS wires for them to stay together and used a toroid.

3. Waited until I had connection to more than 10 sats before flying auto. 

I ran two auto modes both worked well (the second ended abruptly at the second waypoint but that might be related to the problem I am about to explain).

The main issue that I am having now is the same the one discussed in the discussion forum called "AC 3.2.1 APM 2.5 Throttle pulsates in Loiter". As you can see from the image below and the log (named: 2015-04-21 20-18-29.log) attached, although the APM knows that the altitude is increasing and the error between desired alt and barAlt is increasing, it doesn't compensate.


red (barAlt) green (Desired Alt)


I flew again today (4/22) first with an Alt Hold P gain of 1 and then I increased it to 3 and tried it again. 

Stabilization when Alt Hold P gain = 1:


Stabilization when Alt Hold P gain = 3:


Both flight logs are attached in the response I left today at the bottom. 

Alt hold controller seems like it is broken. Not following the desired value at all. 

What now? Tomorrow is my last day to test and fly...


Frame: DJI F450 kit with motors and escs (original)

Autopilot: APM 2.5+

GPS & Compass: ublox RCtimer version (Ublox LEA_6H-0-002  (19) it also says v1.2) I also have a 3DR MTK v2.0 that I can use

I have done autotune to tune the craft. 


2015-04-19 12-40-12.log


2015-04-21 20-18-29.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • I just downgraded to AR2.47 AP3.1.1 AC 3.1.5. will go out and try it in about an hour. I also rolled the gps cable around a toroid. 

      I wonder why I was seeing EKF failsafe errors in logs if APM isn't trying to use them. Maybe it was just the 3.2.1 FW.

      Thanks for the help

  • I have had strange anomalies in the past with some FW releases when loaded onto the 2.6 boards.

    Chased the reasons around for a while, but one day I just erased and reloaded the FW and the anomalies went away.

    So it appears that some thing can be not right in the FW upload or maybe a parameter pointer or something that is not picked up by the verify function.

    Just a thought, easy to try, no harm done if it's not the problem.

    But if you have Loiter working then missions should work fine.

    • I just installed the FW again would that erase the old one completely or just update it?

      Thanks I will give it a try today.

    • Reloading the FW will erase the old version in memory.

      It does not alter the parameters or calibrations though.

    • Please see edit.

  • just my recommendation for such a project!
    Do not use a APM, use a Pixhawk and AC 3.2.1 and It will work If all of your equipment is ok.

    • We do not really have time to switch hardware at this point. Below is a picture of our setup. The GPS is located at the very top of the stack away from the rx. 


This reply was deleted.