no GPS fix after update ?????????????

Hi , :D

this question was posted a few days ago and I have an aditional concern about the GPS matter.

I updatet the APM 2.5 to Arducopter v.2.8.1 hexa with the GPS connected. Would this erase the data from the GPS too ???????

3DR ublox lea6 GPS:
after trying out several things with no success I hope for help from this honorable forum and the experienced members.

About 11 weeks ago I purchased the APM 2.5 FC board and the GPS brand new and original.
The first times I connected and run the boards together via USB on the desk to learn about the
(new to me) functions it worked fine! The MP and Firmware installed perfect and the GPS
found satellites in a few seconds.
Because of time issues I had to leave the boards for about 2 months in the drawer.

Now - restarting with my 'hexa' project I face this problem:
As I found new updates, I download the recent MP(1.2.20) and after connecting the boards
again via USB to the PC - also updated the firmware to Arducopter v.2.8.1 hexa.

And from now on, the GPS won't find and fix satellites anymore !
The red led on the GPS is solid even after 2 hours connected.
The setup, conditions and location is exactly the same as 8 weeks before (when it worked fine the first times).

Any ideas what is going on? What mistake I've made?
The APM 2.5 and GPS was kept connected together with the cable in the drawer. Did this erase something from the GPS?

Please, if someboby read through this lines and could lead me to resolve this GPS issue- would be great because I'm really stuck.

I already reverted back and forth to older versions, uninstalled and reinstalled the MP and let the board connected a long time in case the little back up battery needs a recharge but no way - can't get a GPS fix =(

Any help is appreciated, thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • hi. were you able to find a solution for this. i'm getting the exact same garbage text. 

  • Plug in your GPS ;)

  • I'm having the exactly same problem. Do you realize what happened?

  • @Thomas
    just tried out your suggestion with the "press gently test", but nothing changes during the CLI test for the GPS. The mystery Alt -17 also remains
    (BTW, the back up battery reads 2.88 volts connected to APM or alone.)
    Unfortunately I don't have a FTDI cable and adapter, so I'll contact the shop tomorrow to see what they can do to test the item. I hope they could check the GPS board and repair or exchange it.

    Thank you very much for writing and sharing your ideas !

    Best regards,

  • Admin

    Since you have a LEA-6 GPS and the red power led is lighted then that means the GPS has power. When the GPS has detected a sufficient number of satellites, the blue fix led will begin to flash at a one Hz rate. Is the blue fix led flashing as you have not indicated whether it is flash or not? If it is flashing then the GPS has established a 3D fix. If you are not seeing a 3D fix indication in the HUD on the MP, then there is some kind of problem between the MP and the APM.
    What you might do is go to the Terminal mode and use the CLI to test the GPS to see if the APM can talk to it. Once you are in the Terminal mode and have the command line type "test" and then when the command line reappears, type "gps" and see if there is a response from the GPS.
    Hope this helps.

This reply was deleted.