Non-responsive RC Input in Loiter Mode

Hi all,

I recently switched to an external GPS/compass (3DR) and resolved some EKS variance issues I was having. Woohoo. So, I went out today to test a few things (Loiter being one of them). When switching into Loiter the quad would start to drift and the RC yaw, pitch, and roll (possible throttle) inputs were unresponsive by the craft. That is to say, the quad did not respond to my inputs -- at all. I tried a few times, but to no avail. I have attached the df log below. Taking a look at RCin ch2-4 and RCout ch2-4 shows weird results where the quad was in loiter.

Example: RCin ch2-4 drops to the min PWM value when any stick movement is applied to the RC in loiter mode. See screenshot.


Also, the DVelX vs. VelX (and DVelY vs. VelY) show weird things. See below. Image one is from a normal Loiter's log. Image two is from the attached log. What's also weird is that the DVelX (and Y) and VelX (and Y) do not encompass the entire flight log... Huh?!



Also, for shits and gigs I tried a short auto mission, but the error "No takeoff command given". Of course I had already taken off and was in the air. Note that I have flown this exact same auto mission in the past -- it's just fly to a few waypoints. I'm quite confident they are related.

Anywho, any thoughts on this?

Navio2 hat on an RPI3. Compiled 3.4-rc1.

Austin M


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • RC has been calibrated.

This reply was deleted.