I've just got a pixhawk and am looking to move from my 2.6 to this - Ive done all the calibration on mission planner including the radio setup and all ok. I've tried all at once esc calibration but this didnt work so Ive done this individually via channel 3 and this all workied fine - esc calibrated and motors span up


However when I attached back to pixhawk (stoppped using channel 3 and re attached ppm sum to rc in not sbus in ) although all systems work (GPS etc) and I have green flashing light - I can arm and the light then goes solid green but I cannot get the motors to turn?


Im using futbaba tx and rx

PPM sum encoder

Standard  880kv motors and simonk escs from unmanned tech

all setup calibrations including radio succesful

I'm using a power harness NOT PDB so this maybe the issue?

Otherwise in all at once mode for esc calibration I dont get the same reaction as one at a time - perhaps an arming switch issue? The long tone does sound so this is all ok but then the escs never beep for max to min throttle?


- everything else works and the pixhawk is not reporting any issues - I can arm all ok so bit bemused why the motors wont spin up at all?

any thoughts?




Mark B






You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Its ok Ive solved the issue - it was actually the output from pixhawk - for soem reason the wires were loose (probably pulled too hard when releasing) so there was no signal being sent out - those logs are useful!

  • Hold down the safety switch button until the light turns solid or the esc's make a tone and the props twitch.

This reply was deleted.