Pixhawk - Motors won't spin

Have several pixhawks for a year, so know them pretty well.
After upgraded firmware to "stable" No response to any motors in motor test, ESC calculation or Armed.
ESC's work fine connected directly to transmitter channel 3.
Tried loading in plane firmware and then loading in copter several times. Recalibrate and Arm work perfectly.

No response to any motors in:
1) motor test
2) ESC calculation
3) Armed, no problem arming,
checked in MP and in analysis of logs.

It does seem it has to be a motor parameter problem. I used "find" to look at all the mot and motor parameters and can't see it.
The transmitter calibration is in the expected range.
The ESC calibrate ok when connected to transmitter's channel 3 (throttle). I also plugged a servo into the ESC channels.
I though the Pixhawk ESC and motor test procedure just passed the throttle through to the motors.
Maybe the hardware broke.

How can I channel the ESCs to different output pins to test the hardware?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Had another example that was very hard to find. Upon powerup, my transmitter gave full signal into the ESC. This put the ESC in program mode. Depending on what I did next caused the features of the ESC to reprogram. This made the ESC look broken. But a servo tester and a power supply could reprogram it to default.

    The only way I could get it to work was plug in the ESC power after everything else had settled down.

  • Have you made any progress on this problem? I would like to know what cause this.

    • My solution came as with Mark's above. 1) Monitor what signal levels your transmitter is putting out. 2) With Mission-Planner (MP) monitor what Pixhawk is receiving.

      In our case we had a transmitter channel mix that was preventing the Elev-Aller-Rudd channels from responding to simple hold the Thro at zero and give full right Rudd to ARM.

      On Stable flights, we have extensive professional experience in PID controls, but could not tune PixHawk in any traditional way. So .... We used software defaults and kept the traditional copter/plane CG and thrust geometry to get acceptable performance which we tweaked with just the top level performance parameters in MP. 

      Have been with Pixhawk and APM from the beginning. The software is only tested in a narrow range and any deviations are at considerable risk.

  • I had a similar problem and never really solved it and gave up on Pixhawk and went back to APM controllers.  I had a quad working perfectly with pixhawk.  Then I think I upgraded to a new software load and could not get motors to spin or calibrate or run motor test.  Scoured the DIYdrones forum, Ardupilot forum, RCgroups etc. and saw similar issues but could never quite fix the problem.  I was able to make some progress by ensuring that the baseline parameter set for quads was loaded into pixhawk and by playing around with throttle trim - this got the motors spinning, ran ESC calibration successful, and responding to throttle but could never get a stable flight.  MY setup was pixhawk, turnigy plush 25A ESC, and turnigy 2216 motors.  Let us know if you find out how to fix the problem and best wishes for success.

This reply was deleted.