PixHawk Out of Box Problems

Yesterday I received the PixHawk I ordered on January 2nd.  Four week delivery time is pretty good for a new FC from 3DR!

But I've had all kinds of problems trying to use it. First I tried using the USB connection to a Mac (running OSX 10.9.1) and although the Mac System Information sees a "PX4 FMU v2.x" in the System Information screen APM Planner 2.0 RC3 does not see it and I can't connect to it.  Something is obviously wrong here with my machine's configuration or the installation.

So I dug out my old Windows laptop and after Win8 had finished an hour of updating itself, I tried to connect. Again, no love.  There was definitely something wrong with the drivers, MP wasn't installing them correctly and although the device showed up in the Device Manager, it had an error.  So following this link I manually installed the drivers.

That got me connected but updating the firmware was another exercise in pain.  After the update would start, it would get through the erase and about 25% of the writing portion, then time-out. This happened multiple times after unplugging, restarting, and reseting everything I possibly could.  I then tried doing the update without following the instructions for unplugging the device and it seemed to work.

But my problems continued.  I tried hooking up a FrSky X8R receiver and no signal showed up in the Radio Callibration page.  After again searching the forums here, I found that the Quick Start Guide is wrong. This link pointed out the problem - despite what the Quck Start Guide says, you need to plug S.BUS receivers into the RC port, not the SB port.

So by now I'm hoping I have everything sorted out and I do the Accelerometer calibration.  But as soon as I move the FC, I hear the Windows chimes that a device was removed, then the chimes that a device was added.  WTF???  I opened the Device Manager and repeated the motion.  Sure enough, the connection is dropped, the COM port goes away, then it comes back.

So I drop everything and move from my cold (55° workshop) to my nice warm office and start writing this.  But I can't reproduce the problem.  I turn everything off, go back to the cold area, and after 10 minutes it happens again.

So I've got a thermal problem with my USB connection.  If it was any other company, I'd send the item back for a replacement.  But I know 3DR is really crappy about that kind of thing.  I own 5 APMs of various vintages and I've never had good luck with 3DR Customer Service.  I had an APM 2.6 that had all kinds of I2C errors all the time which I sent back for "repair" but what came back (5 weeks later) was exactly the same.  I very stupidly tried flying a rather nice plane with it and totally lost control from about 50' and destroyed the plane flying into the side of a building.  Needless to say I'm not happy with 3DR Customer Service.

Has anyone else had a problem with their USB connection?  Do you think I should contact Customer Service?  As long as I don't move it when it's cold, everything seems to work fine.  Everything is OK after it warms up.  But it makes doing the calibrations a bit dicey.

When I first opened my package from 3DR containing the PixHawk, I thought, wow, they're really stepping up their packaging, industrial design and out-of-box experience.  Then I turned it on and all my positive thoughts were replaced with frustration.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi bruce, 

    can you help me? 

    I have not been able to load the firmware to my PIXhawk possibly be that the bootloader is not working. Do you know how I can upload firmware to my PIXHAWK?
    thank you very much.

    • What worked for me on an obviously dead Pixhawk:

      Make sure your Pixhawk is powered from a stable 5V supply (like the power cable coming from their voltage sensor).

      Start MP. Go to the Config/Load Firmware screen and choose.

      When it says to "Unplug the Pixhawk, Click OK, and Plug the Pixhawk back in", DON'T UNPLUG IT.

      Instead, push a pen or pencil point into the FMU Reset hole next to the USB port. Press/release.

      The firmware should start loading in a few seconds.

      It took a couple of tries on my second DOA Pixhawk.

  • I just opened brand new pixhawk and problems :

    1. connected to windows 7  via USB cable

    2. port was recognized correctly.

    3. managed to UPDATE Firmware for quadcopter

    4. ... cannot connect to mission planer via USB using mavlink

    I am stuck, I don't know what to try ?

    I have connected ( battery to power module > power module to pixhawk,  3d robotics OEM GPS and compass ( both connected ) , busser connected, red switch connected .

    I tried many times to cycle power and to re-update firmware ( after it says that identical firmware already there so it will not update ) and still no MAVLINK connection via USB.  all is OEM, all is just from the box.

    • I'm pretty sure that 3DR sent me your Pixhawk, Jacek!

      Same symptoms. On just USB, it draws current that's just outside the USB spec. Very different from the last Pixhawk I got. A few percent deviation can be expected, sure, but this is like an LED and a toaster oven.

      It doesn't connect, so 3DR didn't fix it, they just threw it on the RMA-ready pile and here we are.

      I got this one as a replacement for a DOA Pixhawk that arrrived with a bad IMU, probably because the Pixhawk packaging allows the Pixhawk to slam around inside its carton when FedEx or USPS are playing catch with it. Engineers... You'd think they'd catch something as obvious as that. Or, maybe they paid too much for a huge quantity of totally inadequate boxes. Who knows.

      DJI uses a foam insert. That might work, but that inner cardboard carrier would have to be removed.

      Try it: take a packaged Pixhawk and shake it. Hear that? That's a Pixhawk that may as well not have any packaging at all. If your IMU worked, then THAT was an exception!

      Anyway, what is it they say? "Small world."

      Now, I'm shipping yours back (my second defect return, I've never gotten one of these to work). I wonder who will get it next. Maybe we can keep the chain of ownership going here.

    • I have local distributor here in Canada and he just replaced my bad unit with new unit. And before he replaced, he tried mine and he confirmed that something is wrong. Now I have new unit. and here are my findings:

      1. Loaded firmware 3.1.5

      2. all tests PASS ( ACCEL calibration , compass calibration) , tested on quadcopter  ( STABILIZE with NO GPS, ALTITUDE HOLD with GPS, LOITER ) all seems to be OK but!

      3. once a while when I power up I get PRE ARM messages :  BAD COMPASS HEALTH, ALT DISPARITY

      4. usually when I press RESET button next to USB port on the side of PIXHAWK case it resolves issue but sometimes not.

      So I am still not confident with connecting my PIXHAWK to large and expensive HEX or OCTO copter and testing it on cheap quad.


    • I haven't studied the hardware or software enough to be certain, but if I had one that worked as well as yours, I might log the startup sequence and see if there isn't an intermittent  timing issue that occurs only during boot. You could probably fix that in software.

      I'd have to test it a few hundred times before I'd trust a decent gimbal or a GoPro to it.

      I have yet to get one of these past initial setup. My gimbal and GoPro are very safe though!

    • Admin


      Try applying power while holding the arming switch down and wait for the tones to finish to be sure that the firmware has been transferred to the IO.

      Try removing and then reinserting the micro SD card.

      You might try using the FMU reset switch when trying to communicate with the PX4

      Also, try using a powered USB hub.



  • On the Configuration>Full Parameter list page, you can upload a base parameter file for the Pixhawk. Once uploaded, don't forget to write it to the Pixhawk. ;P

    For a first install, it's good practice to start with that. Upload the parameter list, then do careful and thorough calibrations.

    I have 3 Pixhawks, One I haven't installed yet, a customer shipped one, came only 3 wks ago.

    Of the other two, one is an IRIS development Pixhawk ver 2.2 and the other one is a new Pixhawk 2.4.

    Both of those, are working very well. The only "problem" I saw, was the slow roll and pitch offsets, maxing to about 20 deg each, but only when first armed.

    As I say, on later versions, that's gone away, but not to mention having re-done careful re-calibrations of compass and accelerometers.

    The navigation system is very complex, and still in development to some extent. The old calibrations of pre 3.01 versions aren't "good enough" anymore. I noticed with a last calibration I did, I was very careful to hold the quad as closely as I could to "0" in each axis, and try not to move it for a short time in each position.

    Don't know if it is my imagination or some other coincidence, but since this more careful configuration it has been much more stable.

    My workbench is not level, it's off by maybe 3 or 4 degrees. I noticed a big change, when I calibrated the accelerometers on a surface measured with a carpenter's level. Also calibrate compass outside free of any magnetic interference. I have a stereo under my workbench, where the woofers have fairly big magnets.

    So after very careful calibration, and giving it a bit of time after 3D fix, I don't have problems anymore.

  • I had that problem a couple of rev levels ago, but it's seemed to have gotten better up to 3.1

    I haven't tried 3.1.1 yet.

    They tell me, that it's a result of the INS, working in the changing GPS position as it slowly sucks itself in to an accurate value.

    Hmmmm... Anyways, what I have found is that a couple of things help.

    1) Wait a good 3 minutes for the GPS to "suck in"

    2) Movement accelerates the stabilization, that is, GPS data comes in more quickly when it can see relative changes in the sky. I have moved it by hand or even taken it for a short "stab mode" flight before getting into any auto or GPS related flights.

    3) ARMing and disarming a couple of times somehow seems to lessen the offsets.

    Anyways, right now with 3.1, I really don't have to do more than wait the 3 minutes or so and make sure my HDOP is under 2.

  • I'm setting up my pixhawk with the latest beta on a trad heli.
    So far so good up to one point.
    When I arm, the attitude on the information page from telemetry starts drifting nose down on the bench. It goes about 1 degree per second until settling at -30 degrees.
    When I disarm it drifts back up. It ends up at 5 degrees nose low even after calibration. Not sure if that's related.
    Any advice? I seem to remember so business of switching MPUs. Is that the solution?
This reply was deleted.